Brand new CB doesnt work? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 04-22-2012
FMD's Avatar
Thread Starter

FMD FMD is offline
iTrader: (1)
I am: Dave Rules
Join Date: Aug 2005
Location: Amherst NY
Vehicle: 2004 XLT Value Pkg
Posts: 3,803
Total Props: 7
Brand new CB doesnt work?

I bought it on craigslist, still sealed in its box.

Its an older unit... But a nice one. It has 3 wires, ground, switch and Positive.

I tested it on my tractor battery and it worked. So, I hook it all up... and nothing. I take it out, test it again, and still nothing.

Its like it just died. And the inline fuses are in tact. Thoughts?
Reply With Quote
+ 0 -
Old 04-22-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
I am: J J
Join Date: May 2005
Location: San Diego, CA
Vehicle: 2001 Ranger Edge
Posts: 1,179
Total Props: 18
Some units had a small glass fuse inside the case on the PC board.
Reply With Quote
+ 0 -
Old 04-22-2012
rangermainer's Avatar
iTrader: (1)
I am: andrew lapointe
Join Date: Nov 2011
Location: maine
Vehicle: 2002 Ford Ranger
Posts: 252
Total Props: -102
is there a fuse on the positve wire?
Reply With Quote
+ 0 -
Old 04-22-2012
Ranger_Guy15's Avatar
I am: David
Join Date: Apr 2007
Location: MN
Vehicle: 2000 xlt
Posts: 2,827
Total Props: -2
Bad ground?
Reply With Quote
+ 0 -
Old 04-22-2012
06RangerXLT's Avatar
iTrader: (2)
I am: Nate C
Join Date: Feb 2011
Location: Halton Hills, Ont
Vehicle: 2006 Ford Ranger XLT
Posts: 1,685
Total Props: -4
crossed wires and it got toasted?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
horn doesnt work any idea on how to fix it? MikeyFord3 General Technical & Electrical 5 09-12-2008 11:39 AM
my 4x4 doesnt work...suggestions? skh711 General Technical & Electrical 8 09-20-2007 07:17 PM
OHC Map light doesnt work jtslmn720 General Technical & Electrical 3 08-05-2007 08:52 AM
Speedometer doesnt work. PLEASE HELP 99Ranger3.0 General Technical & Electrical 17 02-22-2007 05:01 PM
Active Users link doesnt work for me Zero Ranger-Forums Office 2 01-27-2005 11:04 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 05:12 PM.