A/C problems - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 07-24-2008
Thread Starter

I am: Clay Hicks
Join Date: Nov 2005
Location: Carthage/Tyler TX
Vehicle: 2005 Ford Ranger Edge
Posts: 60
Total Props: 0
A/C problems

Well at the begining of this week my A/C just quite working. Before this happened i had to flip through the switc from defrost to a/c before it would work. Come to find out the compressor was not being energized to lock in. Well I figured it was the switch in the dash causing it to not lock in. I bought the $44 switch and installed it, well it worked for one day. Well we tested it to see it wa only getting 5 volts to the coil. We bypassed the low pressure sensor and high pressure sensor and nothing changed. If you hook a jumper wire into the coil to the battery it locks. If you do that and crank it it will stay locked in. If you swap it to vent the compressor kicks off and when you go back to a/c it kicks back on. If you kill the truck depending on how long it sit without running depends on if it will come on. Now if you turn it to vent then back to a/c it does not come back on nor can you hot wire it and it stay locked. When it stays locked it blows VERY cold air as it always did but you can not get it to lock in without wiring it to the battery. Ford shop told me it could be the clutch, low freone, and even bugs in the evaporator. Anybody think they could help me. We are thinking computer but i'm hoping not. Any questions anybody has to help them with my problem I have no problem answering. Thanks.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 06:35 AM
Clutch problems...possibly?!?!? Help?? ZetaOmegaRanger 2.9L & 3.0L V6 Tech 2 01-04-2008 01:47 AM
Door dinger mod... now problems with blinkers? Zero General Technical & Electrical 4 09-28-2004 10:35 AM
Amp problems Skyjacker_44 Audio & Video Tech 3 08-31-2004 08:52 AM
Driver's side seat belt problems... 98blackranger Interior Semi-Tech 6 06-24-2004 01:07 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 08:31 PM.