EGR & EVAP Monitors not ready - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 08-11-2013
Thread Starter

I am: eric desmond
Join Date: Dec 2010
Location: boston
Vehicle: 2001 ford ranger
Posts: 4
Total Props: 0
EGR & EVAP Monitors not ready

Hello All,

I failed emissions due to EVAP and EGR monitors not being ready. 01 Ranger 2.3 liter, 5 speed 204k miles. Have not changed or disconnected battery lately. Completed drive cycle.
I had it tested with 3/4 tank of gas.

Could it be a bad gas cap? What about a bad fuse? Any suggestions as I am not that familiar with this area of my truck.

Thanks in advance !
Reply With Quote
+ 0 -
Old 08-12-2013
I am: Curtis Duckett
Join Date: May 2013
Location: El Paso, Texas
Vehicle: 2000 Ford Ranger
Posts: 10
Total Props: 0
It may be your gas gap not sealig the system like it should when they did your emissions inspection did they test the cap ?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
EGR vs No EGR any real difference? Nestromo 4.0L OHV & SOHC V6 Tech 9 09-22-2010 10:51 AM
computer not oing EVAP test Falkyn General Technical & Electrical 1 11-15-2007 05:19 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:46 PM.