Electrical issues at 2500 rpm - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-23-2016
Member
Thread Starter
 
Join Date: Nov 2011
Location: Clovis, NM
Posts: 11
Electrical issues at 2500 rpm

Hello good people!

I have an '08 ranger 3.0l 5spd manual w/ 93k mi that I've ran into an issue with and am looking for assistance to see if it's something obvious and/or simple before I run off to the mechanic. I need to get the vehicle up and running (and possibly sold) because I'm moving in 2 weeks.

It's been an issue for a while, but I didn't have the resources/time to fix it and have another vehicle so it was not on my priority list. I didn't drive it almost at all after it started (5-10 miles total for runs to Home Depot when I needed a truck). When I start the vehicle, no issues. Can shift no issues, runs great... unless I rev above 2500 rpm. At that point, the battery light comes on, the headlights dim, cabin light dims (if on), and even the radio display dims. If I drop back below 2500, it goes back to being fine. She idles fine, also.

I just put a brand new battery in her and had bought a new alternator when the problem originally started happening. Neither of these swaps changed anything.
The only electrical I've ever done anything with on it is plugs/wires and a K&N intake that's been on for years.

Any help would be much appreciated and thanks in advance!
Reply With Quote
  #2  
Old 08-24-2016
usr usr is offline
Member
 
Join Date: Aug 2016
Location: Pittsburgh, pa
Posts: 1
I had a similar problem and it turned out to be the fusible links connections corroding. I believe it's the yellow wire that carries the signal to the alternator to charge and it was dropping out because of the corroded connection. That harness is between the battery and under hood fuse box. Also, check the battery connectors, they are crap. I replaced my with the lead repair terminals by drilling them out and soldering them to the battery leads. That was two years ago, no more problems.
The fusible link were fix by cleaning and soldering too. A new harness is about $30.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ABS Light come on at 2500 rpm Ranger5014 2.9L & 3.0L V6 Tech 3 01-28-2016 12:30 PM
98 4x4, rough idle, stutters while accelerating or slowing down, smooth at 2500 rpm likemytruck 4.0L OHV & SOHC V6 Tech 1 06-01-2015 09:39 PM
RPM very limited, can't get over 2000 rpm aj.ash308 4.0L OHV & SOHC V6 Tech 1 05-01-2015 12:02 AM
jingling noise below 1700/ above 2500 rpm scottsdale 2.9L & 3.0L V6 Tech 6 11-01-2011 07:58 PM
droan at 2000-2500 rpm moelll 4.0L OHV & SOHC V6 Tech 3 07-14-2008 12:43 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:00 AM.