Electrical Problem with Starter. - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 05-10-2011
Thread Starter

I am: Dave Reed
Join Date: May 2011
Location: Wheat Ridge, CO
Vehicle: 2004 Ford Ranger Edge
Posts: 11
Total Props: 0
Electrical Problem with Starter.

I have a 1994 Ford Ranger 4x4 XL. I am not getting power from the battery to the fuse distribution box or the starter from the starter relay. I have already changed battery cable harness system, new battery, new starter, new ignition switch, and new relay. When I do get it to run by removing and reinstalling everything, I do get it to run for awhile but then I will go to start it again and no power anywhere, dome, radio, etc. All fuses are good. Ground to chasis is good.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problem with Starter arcadius General Technical & Electrical 1 05-10-2011 09:42 AM
Does this sound like a starter problem? richyrich General Technical & Electrical 6 09-29-2008 02:38 AM
Help Starter Problem! RageRanger General Technical & Electrical 2 02-13-2008 03:13 PM
Starter Problem realhighpockets General Technical & Electrical 10 12-27-2007 10:45 AM
starter problem Don.Hagen General Technical & Electrical 4 10-17-2007 09:32 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:14 PM.