Erratic Tachometer (weird) - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 12-15-2008
seminaryranger's Avatar
Thread Starter

I am: Chris H
Join Date: Apr 2006
Location: Ganado, TX
Vehicle: 1999 Ford Ranger
Posts: 356
Total Props: 1
Erratic Tachometer (weird)

I'm having an issue with my tach lately.
Whenever idling in gear or in park, the tach reads unusually low. After a few seconds, it will eventually bottom out at the 0 peg and stay there. However, it may jump to ~500RPM and fall again to 0 shortly repeating this cycle as long as the engine remains idling.

The engine is not idling as low as the tach is reading. I have verified from my ScanGauge a normal RPM of ~800 in Park.

When the engine speed is raised above idle, the tach seems to function normally and read similar to the ScanGauge.

There are no CEL codes.

Any suggestions?

1999 Ranger 4.0 Sport --SOLD!--

2009 F250 XLT CrewCab ShortBed
5.4L / 6 Speed / 4.10LS
Reply With Quote
+ 0 -
Old 12-16-2008
wydopnthrtl's Avatar
iTrader: (2)
I am: Rich B
Join Date: Dec 2005
Location: SE, Mi
Vehicle: 2006 FX4
Posts: 2,342
Total Props: 0
Not good.. Since the PCM is seeing it accurately it's most likely the guage cluster.

On *other* engines, I've seen the tach jump because of loose wire on plug connections and because of bad ignition modules.

Reply With Quote
+ 0 -
Old 12-16-2008
Igobytwitch's Avatar
I am: Wade W
Join Date: Oct 2008
Location: Cocoa Beach, Florida
Vehicle: 1999 Ford Ranger
Posts: 504
Total Props: 0
Oh, i read it as "erotic tachometer" my bad
Reply With Quote
+ 0 -
Old 04-14-2010
I am: Max Janatsch
Join Date: Mar 2010
Location: Lompoc, CA
Vehicle: 2001 Ford Ranger
Posts: 10
Total Props: 0
I'm having the same problem with my 01 ranger.. Did you get it fixed?
Reply With Quote
+ 0 -
Old 04-14-2010
Blhde's Avatar
I am: Blhde Was here
Join Date: Oct 2005
Location: Northern IL
Vehicle: 1999 Ranger 4.0 SC XLT 4X4
Posts: 2,804
Total Props: 5
My truck is doing the same thing, I have fixed it once.

There is a bad contact for the tach, its on the cluster where the connector plugs in. The thin copper has developed a bit of corrosion, probably form it being touched.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic Idle & CEL? 03R44Edge 4.0L OHV & SOHC V6 Tech 4 04-02-2012 11:24 PM
erratic speedo working during higher speeds JBINWNY General Ford Ranger Discussion 1 11-15-2010 05:06 PM
erratic speedo problems Help 2001fordranger 2.9L & 3.0L V6 Tech 2 07-21-2010 11:13 AM
low gas mileage, erratic idle, and terrible ride rideafatboy04 2.9L & 3.0L V6 Tech 9 02-19-2007 10:25 PM
Erratic idle and hesitation Mike9825 SOHC - 2.3L & 2.5L Lima Engines 8 09-02-2006 03:55 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:19 AM.