Got Car Alram Installed but have a question - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 06-08-2008
robert99ranger's Avatar
Thread Starter

RF Veteran
iTrader: (4)
I am: Mr. Awesome
Join Date: Aug 2007
Location: Indiana/Mississippi
Vehicle: '99 Ford Ranger Flareside
Posts: 5,807
Total Props: 8
Got Car Alram Installed but have a question

(This is on my 99 Ranger) Everything works fine. The only thing is that the LED keeps flashing when you drive down the road. If you hit the dash, the light blinks. And, the stupid dome light stays on for like 15 seconds even after you have started the truck.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Things You Have For Your Ranger But Haven't Installed Yet 05blackranger General Ford Ranger Discussion 38 10-27-2011 10:09 AM
I Know We All Have Rangers But What Else Do You Have? Bart68 General Ford Ranger Discussion 65 11-04-2007 10:48 PM
I installed my CB, but have questions on my PA??? EdGe_wannabe General Technical & Electrical 4 07-23-2005 08:26 AM
Got a set of racing pedals, but have a question. doc Interior Semi-Tech 11 07-18-2005 09:36 PM
i have a 4.0L engine which is great, but i have a brake prob v698ranger 4.0L OHV & SOHC V6 Tech 5 11-02-2004 11:21 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:23 AM.