Heater AND A/C don't work - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 11-15-2013
Thread Starter

I am: Denay Kirby
Join Date: Nov 2013
Location: Lafayette
Vehicle: 1997 Mazda B2300
Drive Type: 4x2
Engine: 2.3
Posts: 3
Total Props: 0
Icon5 Heater AND A/C don't work

Could use some advice here, I recently replaced the timing belt on my 97 Ranger and in the process replaced the thermostat just because it's a hassle to get to and I already had it apart, nothing was wrong with the original.
Started it up after I got it back together and engine seems to be running fine except the engine doesn't warm up and the heater doesn't work like it used to. Was thinking i did something wrong with the thermostat but the A/C is no longer working either. I didn't disconnect the A/C compressor but I did have to move the compressor mounting bracket around while working.
Can't help but think these 2 are related as they both stopped working after the timing belt replacement. Any ideas? Oh, and fan is working, I get air just not hot or cold air.
Reply With Quote
+ 0 -
Old 11-15-2013
ToughTruck's Avatar
I am: Ryan Musgave
Join Date: Nov 2008
Location: Cheney, Washington
Vehicle: 2003 Ford Ranger Edge
Posts: 19
Total Props: 0
Best I can tell you right now is to check your fluid level hoses and fuses. I had a fuse go out on me on my 03 and all it would do was blow. No hot or cold air.

How long are you letting it run? Does it get to normal operating temp after you drive it?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater wont work (how to diagnose and fix) dogfish246 General Ford Ranger Discussion 0 11-20-2014 08:01 PM
90 Ranger 2.9L block heater in heater hose?? doug Rooney 2.9L & 3.0L V6 Tech 0 12-07-2013 07:52 AM
Heater don't heat cliffg General Ford Ranger Discussion 8 06-05-2011 09:25 AM
Coolant leaking from the heater control on the heater hose T The_Dealer 2.3L & 2.5L I4 Tech 2 11-01-2007 02:44 PM
GIF's don't work....(for me) Mnemonic Ranger-Forums Office 5 01-19-2005 08:12 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:47 PM.