HELP!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 05-03-2009
slyhog's Avatar
Thread Starter

I am: William Cunningham
Join Date: Nov 2007
Location: Grand Prairie
Vehicle: 2004 Ford Ranger Edge
Posts: 15
Total Props: 0

ok i got a 2004 ranger edge. one morning i went out to my truck to head out to work and as i always do i turn my headlights on , i firmly belive in using headlights all the time, so i turn them on just the headlights and all of the sudden i got not only the headlights but i got windshield washers and wipers high speed, horn continualously blowin and the thing just got a mind of its own!!!!i was just wondering if anyone else out there has had this problem or heck even a good wiring diagram so i can see how if any way at all the 3 swithes are even any way tied together, and when i turn lights off they dont go out, i can hit my washer swithch and turn on park lights and all sort of weird stuff. any help at all would be helpful. please and thank you, kinda tired of have to pull a fuse to kill power to everything
Reply With Quote
+ 0 -
Old 05-03-2009
iTrader: (1)
I am: Josh B
Join Date: Jun 2008
Location: Livonia, MI
Vehicle: 2000 Ford Ranger XLT
Posts: 489
Total Props: 1
Unhook your battery and let the truck sit for like 5-10 minutes to reset the computers. That may fix it.
Reply With Quote
+ 0 -
Old 05-03-2009
Rev's Avatar
Rev Rev is offline
Level I Supporter
I am: J J
Join Date: May 2005
Location: San Diego, CA
Vehicle: 2001 Ranger Edge
Posts: 1,179
Total Props: 18
Could be a bad Multifunction Switch in the steering column
Reply With Quote
+ 0 -
Old 05-04-2009
bjohnson238's Avatar
I am: Brian Johnson
Join Date: Nov 2008
Location: Muncie, IN
Vehicle: 1990 Ford Ranger
Posts: 732
Total Props: 0
Sounds like a short in the wiring.
Reply With Quote
+ 0 -
Old 05-05-2009
I am: Ken Here
Join Date: Mar 2007
Location: Upstate,NY
Vehicle: 2003,Ranger
Posts: 2,598
Total Props: 13
Bad cab/chassis ground.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP !HELP! HELP! 3.0 V6 Driving me insane Hunter74 2.9L & 3.0L V6 Tech 21 03-06-2016 11:08 AM
Help Help Help!!!!!!! EdgeGOBoom 2.9L & 3.0L V6 Tech 6 09-16-2007 12:01 AM
Help Help Help Gear Indicator Stuck BananaEdge General Technical & Electrical 5 06-15-2005 11:05 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:37 PM.