idle problem - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 09-27-2012
Thread Starter

I am: Robert Jacobson
Join Date: Aug 2012
Location: mission viejo, ca
Vehicle: Ford Ranger
Posts: 4
Total Props: 0
idle problem

I have a 97 ranger XTL with 311780 miles on it and I am having problems with the idle. when I first start it up it runs up and down dose not want to settle down until it gets warm. I have replaced several of the componets including all the emission control sensors, Throttle position sensor, mass airflow sensor, IAC Valve, EGR, EGR Vacuum regulator sensor, PCV Valve, carbon canistor valves and all vacuum hoses as well, new coil and wires, spark plugs, air flow sensor and it is still doing it. I need help could someone give me a few idea's on what they think it could be please it is driving me crazy.
Reply With Quote
+ 0 -
Old 09-27-2012
rangerrunner11's Avatar
I am: . .
Join Date: Feb 2011
Location: .
Vehicle: 2000 Ford Ranger XLT 3.0
Posts: 1,018
Total Props: 8
Check for vacuum leak.

sounds like unaccounted air is slipping into the motor.

with replacing loads of parts its likely air is getting in some how, time to cigar test it
Reply With Quote
+ 0 -
Old 09-28-2012
patkelly1336's Avatar
I am: Patrick Kelly
Join Date: Mar 2011
Location: Elm Grove, Wisconsin
Vehicle: 2008, Ford Ranger, XLT
Posts: 209
Total Props: -1
I had this problem awhile ago, and my issue was a blown thermostat (it was a fail-safe thermostat, so it causes it to be stuck open) and this causes the engine to take longer to warm up, causing idle problems until the temperature gauge went to the middle (normal range). I don't know if this helps, but its either this or a vacuum leak
Reply With Quote
+ 0 -
Old 09-18-2013
I am: Allan Camden
Join Date: Sep 2013
Location: douglasville ga
Vehicle: 2003 Ford ranger
Drive Type: 4x2
Engine: 4.0
Posts: 1
Total Props: 0
hunting, hanging idle

03 ranger 4.0, ive replaced everything possible, including the motor for to the death rattle, long story. any how, I had a hanging idle, sometimes slow to return to normal, bad gas mileage and poor performance, I thought I was pulling a trailer a times, a slight hill would turn into a mountain. let my expensive endeavor of throwing parts become your benefit. go to the salvage yard and get a throttle body with the TPS still attached, clean it and install, problem solved. salvage yard will run you 45-60$, New 300$. my power is back, idle returns quickly and idles smooth.. good luck
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 04:06 PM
low idle when slowing down to idle j_huhnke General Ford Ranger Discussion 13 04-06-2012 04:58 AM
High Idle / Low idle 2003 Ranger 3.0 thom2003 2.9L & 3.0L V6 Tech 1 03-27-2012 12:12 AM
low idle when slowing down to idle j_huhnke 4.0L OHV & SOHC V6 Tech 2 03-25-2012 09:26 AM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 11:49 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 07:08 PM.