Lights not working... - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 12-27-2010
Thread Starter

I am: Omar Estrada
Join Date: Jan 2009
Location: Mission, TX
Vehicle: 1999 Ford Ranger
Posts: 24
Total Props: 0
Lights not working...

Tail lights aren't working as well as fog lamps and parking lamps. But when I put the turn signal on signals blink. Already checked all fuses and seem to be working fine. Disconnected the battery, plugged it back in and nothing... Wiring seems fine... I activate/deactivate my alarm lights blink like normal. I turn the parking lamps on and the gauges don't light up

any help?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake lights not working. It's not the brake switch. ColinGooseHall General Technical & Electrical 3 05-01-2015 07:35 PM
Ranger not charging and chime not working jfoster2505 General Technical & Electrical 3 02-14-2012 07:23 PM
Heater not working/not shifting right conrad General Technical & Electrical 7 01-20-2011 05:35 PM
HVAC lights, headlight switch light, 4wd lights not working.... Jwad00 General Technical & Electrical 1 09-05-2009 03:45 PM
back up lights not working 99RangerXLT General Technical & Electrical 4 09-24-2007 08:12 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:38 AM.