Multiple electrical failures - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 2 Weeks Ago
Thread Starter

I am: Evan Freeman
Join Date: Oct 2016
Location: Panorama
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 1
Total Props: 0
Multiple electrical failures

Hey thanks in advance or any help or advice.
I have a '94 Ranger 4x4, 5spd manual.
All at once my Instrument cluster backlight cut out, brake/tail lights cut out and ABS light came on blinking. I checked all the fuses and everything looks good. Turn indicators still work, hazard lights still work, and the headlight/interior dimmer switch still works fine. Seems like a broken wire or a bad harness somewhere, but everything looks tight and clean. Which harnesses should I be checking specifically? Seems like something running to the rear end. FYI the previous owner added a trailer brake, and some of his wiring seems questionable.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
First real 'failures'! coyttl Drivetrain Tech 0 03-24-2013 12:03 PM
CV shaft failures icthusrulz Drivetrain Tech 8 08-28-2009 08:03 PM
Multiple Questions Yessick Drivetrain Tech 32 09-12-2008 12:27 AM
Check Engine light, multiple codes...argh TippsTheFoo 4.0L OHV & SOHC V6 Tech 16 08-14-2007 08:49 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:30 PM.