My 4X4 button doesn't work! - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 08-10-2009
94'RangerGuy's Avatar
Thread Starter

I am: Michael Maciejewski
Join Date: Mar 2009
Location: Tracy, Ca
Vehicle: 1994 Ford Ranger XLT
Posts: 67
Total Props: 0
My 4X4 button doesn't work!

I have a 1994 Ford Ranger XLT 4.0L V6, and when I first bought my truck last year the 4x4 was moody and would turn on and off but it was delayed a lot, but now it does not go on all together? Any advise
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Low Range doesn't work? 91ExtCab Drivetrain Tech 2 10-15-2008 05:51 AM
1995 heater doesn't work....common? TXST8tj General Technical & Electrical 4 03-15-2007 03:11 AM
4x4 doesn't work, no lights, no nothing Gerardo Drivetrain Tech 7 11-27-2006 12:17 PM
lock doesn't work, 91 ranger xlt, any ideas? Bhavesh Interior Semi-Tech 1 10-30-2006 10:54 AM
IAT mod on FFV engines -- doesn't work properly n3elz 2.9L & 3.0L V6 Tech 29 03-08-2005 11:12 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:41 AM.