mystery motor water pump fiasco.... - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 07-16-2014
Thread Starter

I am: Patti Nunley
Join Date: Jul 2014
Location: Seattle, WA
Vehicle: 1981 Ford Ranger
Drive Type: 4x2
Engine: ??
Posts: 12
Total Props: 0
mystery motor water pump fiasco....

I'm REALLY new here. I bought an 81 ranger in Dec. Its been a great work truck but I've got a mystery motor ( I mentioned that in my introduction on the getting to know you thread) my buddy Bill down at O'Reillys and I have kinda narrowed it down to a 70's mseries big block. ( I get the idea of what that means. ) anyway. been running alright for "an old farm truck" and water pump went out on sunday. the water pump was mounted flush to the timing cover. no plate between just a gasket and rtv. I've been told by someone at car quest that there should have been a plate between the water pump and the timing cover. there wasn't one attatched to the old water pump and there wasn't one with the new one. and I'm mechanically inclined enough to realize when bolts will not reach to seat right. if I were to add the plate then the two gaskets there is no way that some of the shorter bolts would fit. with this being a "mystery motor" and the water pump had worked fine for quite a while concidering the age and crustiness of the old gasket. is it possible that this is how the motor came? and that I am safe in replacing it the same way? I've GOT to get this big girl running so I can get back to work.


Last edited by TheMint; 07-16-2014 at 03:29 PM. Reason: adding information.
Reply With Quote
+ 0 -
Old 07-18-2014
iTrader: (2)
I am: Kevin
Join Date: May 2014
Location: Lake Mary, Florida
Vehicle: 2000 Ford Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 348
Total Props: 0
Any chance you could snap a few shots of this engine and post them? Pictures will help in identifying this engine.

What about the engine casting number, or serial number? Post that too, as sometimes you can get lucky in a Google search....

As to the water pump; did it run that way without the plate that you are aware of? If so, you'd have your answer, and I'd simply duplicate it on the new water pump install.
Reply With Quote
+ 0 -
Old 07-18-2014
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,726
Total Props: 88
The timing chain cover is the back plate of the water pump, that is normal on many V8 Fords.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mystery water leak on passenger side floor awcraig General Ford Ranger Discussion 31 01-03-2016 04:35 PM
mystery motor TheMint General Technical & Electrical 3 07-16-2014 08:19 AM
Mystery hose coming out of firewall under wiper motor. Dan R 2.9L & 3.0L V6 Tech 4 09-25-2011 12:19 AM
Water pump and oil pan questions... TBarCYa General Technical & Electrical 7 04-06-2005 08:05 AM
well water or hard water Diabolic General Ford Ranger Discussion 4 10-21-2004 04:52 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 02:24 PM.