New to Forum - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 11-14-2010
Thread Starter

I am: Dave McLean
Join Date: Nov 2010
Location: Palm Coast
Vehicle: 1998 Ford Ranger
Posts: 4
Total Props: 0
New to Forum

I am new here on the site. I have a problem with my 98 ranger and was wondering if anyone could help? My wipers as well as power windows and dome light does not work. I have checked all fuses and none are blown. I would appreciate any help.
Reply With Quote
+ 0 -
Old 11-14-2010
ranger4.0's Avatar
iTrader: (1)
I am: kyle chabot
Join Date: Jul 2009
Location: cambridge, ontario
Vehicle: 2005 Ford Ranger XLT
Posts: 3,922
Total Props: -11
welcome... it sounds like it has to be something fuse or relay related... im assuming you checked all fuses in both panels?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
New to the Forum...New to Rangers 01rangerstang03 Member Introductions 11 06-15-2010 09:03 PM
New to this forum but not new to Rangers Old97 Member Introductions 16 11-01-2009 03:11 AM
New Ranger, new to the forum, old Ranger fan... talon63 Member Introductions 13 07-07-2008 10:11 AM
Not sure if this is the right forum... problem with forum Wowak Ranger-Forums Office 6 08-04-2004 01:13 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 05:52 AM.