odo not working - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 04-24-2011
Thread Starter

I am: Kevin Eicher
Join Date: Jan 2011
Location: San antonio, texas
Vehicle: 1995 Raner 2.3
Posts: 12
Total Props: 0
odo not working

1996 ranger 2.3, the speedometer works fine but the odometer is not working. Is there a secondary sensor or is the module in the dash not working?
Reply With Quote
+ 0 -
Old 04-24-2011
drppdyllwrngr's Avatar
iTrader: (4)
I am: Troy Stevenson
Join Date: Sep 2007
Location: wilmington, nc
Vehicle: 95 ford ranger, 93/98/03
Posts: 2,096
Total Props: -1
more than likely need to replace the odometer. it has plastic gears and they tend to strip out.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo quit, but ODO working. LastStarfighter General Technical & Electrical 6 02-19-2012 08:22 PM
98 ranger speed/odo problems bclements515 4.0L OHV & SOHC V6 Tech 8 06-26-2011 07:39 PM
Speedo and Odo issues redhawk15 2.9L & 3.0L V6 Tech 19 08-06-2010 09:38 PM
95-4 cyl..odo quit and general ?s fearfact General Technical & Electrical 0 03-31-2010 09:55 AM
Swapped clusters, now no speedo / odo... W1CKY General Technical & Electrical 5 09-26-2007 09:32 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:23 PM.