our new car has a lil problem... - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 05-20-2008
swamper06's Avatar
I am: Tim K
Join Date: May 2007
Location: McAdoo, PA
Vehicle: 2006 Ford Ranger XLT
Posts: 735
Total Props: 0
Good for you dude.
Reply With Quote
+ 0 -
Old 05-20-2008
quicksilver2001's Avatar
I am: Justin Dupre
Join Date: Dec 2004
Location: Opelousas, Louisiana
Vehicle: 2002 Ford F-150 FX4
Posts: 704
Total Props: 0
good to hear, that thing could've had numerous problems yall didnt know about yet
Reply With Quote
+ 0 -
Old 05-20-2008
GrafixGuy's Avatar
Thread Starter

RF Veteran
iTrader: (3)
I am: Cody E
Join Date: Jan 2005
Location: Montgomery, AL
Vehicle: 2007 Ford Ranger Sport
Posts: 8,703
Total Props: 0
yep, mom got her old car back so everything good...
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
new pics with a lil mud and new tires 04_xlt_4.0_4x4 Snapshots 27 03-31-2009 01:01 PM
our rangers our tough redranger04g Vehicle & Meet Videos 22 03-30-2008 07:40 PM
**2.9 juttering problem, lil help please!!!! pushdeck 2.9L & 3.0L V6 Tech 8 07-28-2007 07:12 PM
Our 2000th Member Has Joined... Trevelyn1015 Ranger-Forums Office 18 09-26-2005 11:05 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 02:02 PM.