Possible computer problem? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 04-06-2010
Thread Starter

I am: BB Kul
Join Date: Apr 2010
Location: Glastonbury, CT
Vehicle: 2006 FX4 Level II
Posts: 1
Total Props: 0
Possible computer problem?

Hey all im new to this forum but figured it would be a good place to ask for help considering the lack there of ive gotten at the Ford dealer. This summer was the first time the problems in my Ranger started, went to go get it detailed and the engine sounded like it was turning over yet it wouldnt start, got it towed to the dealer where it sat over the weekend, they called and said it started up fine and theyd been driving it almost constantly to try and get it to not start so their computers could tell them what was wrong. Long story short they never found out, drove it a month or 2 w/out problems until it happened again and the same thing happened; it started right up for them and they couldnt find out what was wrong. Fast forward 6 or 7 months and just this weekend i was out with my girl when i noticed my check engine, oil and battery lights all came on and i couldnt accelerate and i lost my power steering, managed to get it stopped along the side of the road and went to start it, RPMs bounced around .5 to 1 and died, I went to tell the family whos house i broke down in front of i was getting it towed, few mins go by and i went to start it and it started up and ran fine, pulled into a parking lot and my RPMs started dropping fast and the engine died, waited a few minutes it started up fine, and a minute or two later the RPMs dropped and the engine died again, so i get it towed again and the dealer is telling me the same thing, they cant find a problem, some buddies told me that happened to them and it was a quick computer switch. So I'm asking you guys what the problem possibly could be, how much it will run me and also if the dealer cant replace anything if its safe to keep driving with the risk of it breaking down again. Thank you all in advance.

Also the truck is a 2006 FX4 Level II I got it a little over a year and a half ago and put on close to 40,000 miles
Reply With Quote
+ 0 -
Old 04-06-2010
98rangerxlt's Avatar
I am: Evan Nelson
Join Date: Mar 2009
Location: Bakersfield, CA
Vehicle: 1998 ford ranger
Posts: 725
Total Props: 1
Sound more like the fuel pump to me
Reply With Quote
+ 0 -
Old 04-06-2010
Level I Supporter
I am: Bob Ayers
Join Date: Aug 2006
Location: Durham, NC
Vehicle: 1999 Ford Ranger
Posts: 3,654
Total Props: 3
Scan for codes and see if anything shows up. It could be the PCM or fuel pump relay, or crankshaft position sensor.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
strange- shifting easier after emission test? computer problem? Bobburt444 General Technical & Electrical 3 07-02-2011 11:42 AM
need 93 ECM computer and harness if possible chirojoseph General Ford Ranger Discussion 1 11-29-2010 08:20 PM
Possible torsion bar problem Mykhael General Ford Ranger Discussion 7 10-21-2007 01:47 PM
Possible Oil Pessure Guage Problem garymurch General Technical & Electrical 13 12-12-2006 03:28 PM
Possible OHC temp sensor problem aftermarket General Technical & Electrical 22 06-01-2006 04:04 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:05 PM.