RPM and Electrical - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 12-04-2010
Thread Starter

I am: Strohaway Trucking
Join Date: Mar 2010
Location: G-town NY
Vehicle: 03 Ranger
Posts: 4
Total Props: 0
RPM and Electrical

Ok so here I am coming home from dropping my kids off and have this hill to climb. Done this a thousand times in the past, well as the truck down shifts 3/4 the way up I lost power and all my lights dimmed and the battery light comes on. HMMM I think and let off the gas and everything goes back to normal. After cresting the hill I give 'er the gas and all is good, so I give 'er some more and get it to down shift. Sure as **** it does it again. I get home and in the garage we go, I throw on the Volt meter and get 14-14.2 at idle. Ok that's good and the battery is at 12.5, great. So I figure I'm getting a low idle read, i take the cover off the throttle body to get at it to crank up the RPMs and watch the meter. No go start sputtering and **** but the meter still read 14 so I guess the alternator and regulator are good. But know I have this problem with no rpms. I get in the truck and throttle it up to see what I'm getting, DAMN 3000 and nothing more!!!! Now I am sitting here reading through the forum trying to find some answers and nothing to compare to this mess I have. Now if this was a Carbed V8 I would have no problem fixing it. These computer controlled cars I have no clue. Its an 03 2.3l with 52000 miles on it, any suggestions would be HIGHLY APPRECIATED!!
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM very limited, can't get over 2000 rpm aj.ash308 4.0L OHV & SOHC V6 Tech 1 04-30-2015 11:02 PM
Misfire at low rpm's and codes p0171 and p0301 geralddh15 2.9L & 3.0L V6 Tech 1 07-26-2012 11:01 PM
new guy with a couple electrical problems and maybe a mechanical issue and a couple bonzo 1 General Technical & Electrical 5 12-27-2009 05:09 PM
96 Ranger Stalls and Misses when Accelerating and Low RPM's acleme1 2.9L & 3.0L V6 Tech 1 10-03-2008 06:32 AM
Tire sizing and RPM a311fanam Wheels & Tires Semi-Tech 15 06-19-2005 04:47 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:23 PM.