some weird electrical probs??? please help - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 08-30-2010
Thread Starter

I am: mark bates
Join Date: Aug 2010
Location: dallas, tx
Vehicle: 1992 ford ranger
Posts: 4
Total Props: 0
some weird electrical probs??? please help

i have a 92 ranger that up untill yesterday drove great. i went to the store drove it home and parked it for the night. i tried to start in the morning and nothing. it has plenty of battery life so i started trouble shooting and i was able to start via crossing the terminals on the starter. so i figured it was my clutch safety switch. so i bypassed and still nothing. dont worry was gonna replace if it was the issue not leave it bypassed. but anyways it didnt help. since then ive noticed the horn no longer works and my amplifier wont come on. ive checked all the fuses none are blown. no sighns or smells of eletrical wires burning. im stumped. can a bad ignition switch be the cause of all these problems? or am i missing something? any help or info would be great. let me just thank yall in advance..........thanks oh and sorry didnt think my last post got put up. but i see it did oooops

Last edited by lonestar27; 08-30-2010 at 07:23 PM.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Electrical Issues. Any help will be great! Ranger-Danger123 General Technical & Electrical 2 08-05-2014 06:16 AM
2000 Ranger Headlamp/Electrical Probs timboothe General Technical & Electrical 9 12-23-2011 10:32 AM
weird Electrical connector undead455 General Technical & Electrical 4 12-22-2010 07:37 AM
Really Weird Electrical Problem Mitch_71 General Technical & Electrical 5 03-07-2010 12:46 PM
Weird electrical issue uhittheuglytree General Technical & Electrical 2 02-19-2010 02:07 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 07:22 AM.