squeaking noise when the truck is cold for about 10 minutes - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 02-11-2008
Twisted Ranger's Avatar
Thread Starter

I am: Mike Robinson
Join Date: Oct 2007
Location: Frederick, MD
Vehicle: 2006 Ford Ranger XL 3.0 5spd Regular Cab
Posts: 33
Total Props: 0
squeaking noise when the truck is cold for about 10 minutes

it sounds like it is coming from the front end but I can't be sure, Does anyone have similar problems or am I freaking out for nothing?
Reply With Quote
+ 0 -
Old 02-11-2008
Roach2004's Avatar
RF Veteran
iTrader: (3)
I am: a Roach
Join Date: May 2005
Location: Houston, TX
Vehicle: 2004 Ford Ranger EDGE
Posts: 8,320
Total Props: 0
Edit: I thought you ment AFTER its off
Reply With Quote
+ 0 -
Old 02-11-2008
mudranger96's Avatar
I am: Brett .
Join Date: Oct 2005
Location: Lehigh Acres, FL
Vehicle: 2002 Ford Ranger FX4
Posts: 2,549
Total Props: 0
check your pulleys, mine use to do the same thing. I noticed my idler pulley had a slight wobble in it while the truck was running, i replaced it and the noise went away.
Reply With Quote
+ 0 -
Old 02-12-2008
I am: Carl Darnell
Join Date: Dec 2007
Location: Taylorsville Ky
Vehicle: 2003 Ford Ranger Edge
Posts: 289
Total Props: 0
You better check for the cam position sensor and dist. There seems to be an issue with them on the 3.0L. It could be a sliping belt. Try taking the belt off and see if it still squeals.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squeaking noise coming from rearend of truck! BlackNGoldRules Suspension Tech 22 07-30-2009 01:18 PM
Squeaking Noise on the front left tire TheRiot Drivetrain Tech 9 07-07-2008 07:02 AM
squeaking noise in reverse 04 EDGE Drivetrain Tech 11 05-06-2008 07:54 PM
Truck Wouldnt Start 20 Minutes Ago? Roach2004 General Technical & Electrical 11 03-28-2007 09:39 AM
Pouring noise when starting truck for a couple minutes..... Jeremy102579 2.9L & 3.0L V6 Tech 4 01-27-2007 09:57 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:57 PM.