taylor spiro pro wires JUNK!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 05-11-2016
cheese_man's Avatar
Thread Starter

iTrader: (1)
I am: david fowler
Join Date: Nov 2009
Location: arthur
Vehicle: 2013 transit
Drive Type: 4x2
Engine: 2.0
Posts: 2,011
Total Props: 4
taylor spiro pro wires JUNK!!!!

well about 6 months after i installed them , they are now leaking heavy EMI

so much so that my fuel economy dropped like a rock

so i am having magnecor custom make me a set of the 10.5 mm CN25 series ignition wires

anyone else suffering mileage issues your ignition wires are the problem

how can i tell , easy emi interferes with local radio broadcasts, especially when the engine idles .

you can hear low level whining , if your hearing is still good
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plugs/Wires (wires bad) ROSCO 4.0L OHV & SOHC V6 Tech 8 11-02-2011 11:01 AM
For Sale: (4) 33x12.50R16 Pro Comp Xterrain's on polished 16x8 Pro Comp 1079's - OR 03whtEDGE Suspension, Tires, & Wheels 2 07-27-2010 06:32 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 12:42 PM.