Trouble with cluster lights - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 10-02-2007
Texas501's Avatar
Thread Starter

Join Date: Aug 2006
Vehicle: 2008 Ford Ranger Sport
Posts: 151
Total Props: 0
Trouble with cluster lights

OK, so I have no lights for my odometer; my ***** for the a/c, 4x4 switch; no lights for all needles (gas, speed, tach, temp, oil, voltage); no light for my transmission indicator (P N D 1 2). I do have overlays for the cluster face and they work fine (have been installed for over a year now without problems).

I checked ALL the fuses (inside the cab on driver's side dash panel, and under the hood) and all seem intact. I played with the dimmer switch, of course nothing happens, but it does still turn on the dome light and bed light (on third brake light).

Could the dimmer switch be bad (I replaced it over a year ago)? Did I miss a hidden fuse some where that controls these lights? Any help would be appreciated.

Oh, I drive a 1998 XLT 4X4 4.0L supercab.

Originally Posted by Rolldogg
But if it's the Doom Light.....I'd check the Nostradamus switch.....LOL
Reply With Quote
+ 0 -
Old 10-02-2007
I am: Earl ?
Join Date: Nov 2005
Location: Elizabeth City, NC
Vehicle: 2000 Ranger XLT 4x4
Posts: 767
Total Props: 0
Probe the LB/RD wire coming out of the dimmer.
If it's got power, and varies with the dimmer wheel, check G200 near the DS fusebox in the cab. I think more would be inop if G200 was bad tho'.

If you didn't have power out of the dimmer, LB/RD, then probe the BN wire going in the dimmer. If no power there, then your parking lights probably aren't working either. Then it's either the Parking Lamp Relay or the Main Light switch, or a fuse.
Reply With Quote
+ 0 -
Old 11-05-2007
I am: bill thompson
Join Date: Jun 2007
Location: jackson
Vehicle: 2001 xlt Ranger
Posts: 7
Total Props: 0
It could be the bulbs in the dash. I had the same problem several months back. I remove the dash and replaced the bulbs from auto zone. They were pretty cheap. Took a couple of hours to fix.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
No tail lights or gauge cluster lights, HELP PLEASE. Shaggy General Technical & Electrical 2 02-17-2013 09:45 AM
2001 cluster to a 2004+ cluster swap? J's Ranger General Technical & Electrical 1 10-17-2011 04:30 PM
For Sale: Or Trade: Silver Gauge Cluster aka 03 XLT Cluster/Chrome Chambers(VA) RangerNDog Interior, Exterior, Electrical, & Misc. 9 10-21-2009 12:58 PM
Trouble Trouble.. Alex98 4.0L OHV & SOHC V6 Tech 0 11-10-2007 03:22 PM
explorer sport trac cluster trouble with intall. zabeard General Technical & Electrical 8 12-27-2005 05:33 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:45 PM.