Turn signals sometimes work - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 01-03-2016
Thread Starter

I am: Laurie McDougall
Join Date: Jan 2016
Location: Coquitlam BC
Vehicle: 2010 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 1
Total Props: 0
Turn signals sometimes work

Hi all! I am glad to have found this forum 😊 I recently got my dads 2010 4x4 ranger 4liter motor.
I don't think he used it much as it has only 30k on the odometer and still has that new car smell. (Dad is/was94) anyway the turn signals "froze" the other day, so I checked the bulbs and they are all good.
I started her up this morning and the turn signals (and 4wayvflashers) worked fine. I did a little bit of experimenting and discovered that if I use the high beams then the signal lights freeze. If I turn the engine off for a minute or so then start her up again then the signals/4 way flashers work fine.
I am guessing that the problem might be some sort of module in the steering column?
Thanks for your help!
Reply With Quote
+ 0 -
Old 01-03-2016
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,767
Total Props: 88
2010 Ranger will use 1 wire to each rear bulb for both turn signal and brake light signal.

The multi-function switch(turn signal stalk) is what controls that.

Wire from the brake pedal switch runs up to the multi-function switch, if turn signals are off then brake light power runs thru the switch and both rear bulbs light up.

If you turn on the turn signal then it will cut brake light power on that side and pass flashing power to the bulb on that side.

You could try a new flasher, there are two of these, one for turn signals, one for 4-ways

But your description that turning on the High Beams(using multi-function switch) causes a failure makes me think problem would be in that switch, not the flasher or wiring.
Reply With Quote
+ 0 -
Old 01-15-2016
I am: dave tyler
Join Date: Jan 2016
Location: joplin, mo
Vehicle: 2001 ford ranger
Drive Type: 4x2
Engine: 3.0
Posts: 3
Total Props: 0
2001 ranger right front turn signal has quit working, the other 3 work fine.
I replaced the bulb twice (they come in pairs thot maybe bad from factory),
The fuse is for all 4 and is good and the parking light works. HELP!!!!
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Reverse lights and turn signals dont work FMD General Technical & Electrical 1 04-25-2015 07:35 AM
94 ranger turn signals won't work! v6 4x2 all other lights and wipers work not fuse? kappesdeb General Technical & Electrical 0 07-17-2014 11:45 AM
Turn signals don't work 88 Ranger mike perez General Technical & Electrical 0 08-02-2013 06:05 PM
Can someone please help me get my turn signals/hazards to work? DSMissed General Ford Ranger Discussion 14 12-26-2009 01:54 PM
Turn signals stopped working on my 94, hazzards work ecnovaec General Technical & Electrical 10 03-31-2009 06:58 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:52 PM.