Weird Problem - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 08-03-2007
Thread Starter

I am: Bryan Hoffman
Join Date: Nov 2006
Location: Valdosta, Georgia
Vehicle: 1999 Ford Ranger XLT 4x4
Posts: 18
Total Props: 0
Weird Problem

I have an 99 Ranger 4x4 XLT 3.0L automatic. i was driving at about 65-70mph and decided i wanted to go faster, so i punched it, it shifted down twice (which is normal), the speedometer read 70 and jumped up to 80 really fast and simultaniously my ABS light came on. I pulled over shut the truck off and started it back up and the light was off. What is the problem?

Reply With Quote
+ 0 -
Old 08-03-2007
iTrader: (1)
I am: Josh Heaton
Join Date: May 2006
Location: Portage, IN
Vehicle: 1997 Ranger XLT
Posts: 350
Total Props: 0
Not that I'm technically qualified to answer this, but I believe the speed sensor is part of the ABS unit. Not sure mechanically what is going on but it makes sense the two are interconnected. Perhaps someone else can chime in and point you in the proper direction.
Reply With Quote
+ 0 -
Old 08-03-2007
rwenzing's Avatar
RF Veteran
iTrader: (4)
I am: Bob .
Join Date: Nov 2004
Location: Michigan
Vehicle: 2003 Ford Ranger
Drive Type: 4x4
Engine: 5.0
Posts: 7,773
Total Props: 19
The rear axle ABS sensor is also used as the source of the raw vehicle speed pulse on 98~2000 Rangers. That sensor does sometimes fail with symptoms like yours. It is relatively cheap and easy to replace.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
stumped...weird headlight problem wvcat General Technical & Electrical 12 08-29-2008 12:05 PM
Weird idle problem when putting truck in neutral coming to stops. Jeremy102579 2.9L & 3.0L V6 Tech 13 03-25-2007 09:26 AM
Weird Brake Problem? Roach2004 General Ford Ranger Discussion 11 03-20-2007 09:55 PM
weird radio problem, please help TippnOver General Technical & Electrical 12 12-03-2005 03:44 PM
Weird brake problem... Zero Drivetrain Tech 3 06-05-2005 01:00 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 01:25 PM.