winshield wipers wont work - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 12-02-2007
Thread Starter

I am: Jeremy Schultz
Join Date: Sep 2007
Location: Livonia, MI
Vehicle: 1992 Ford Ranger
Posts: 4
Total Props: 0
windshield wipers wont work

I have a 1992 ford ranger 3.0 v6 manuel transmission. My windshield wipers stopped working in any speed. When I turn them on I can hear a clicking noise from under the dash the corisponds to which speed I set the wiper switch to. I replaced the wiper motor in hopes that it would fix the problem, but they still will not work. I tryed the new motor before i hooked up the linkage and it will not run at all.the multifuction switch seems to be working fine becasue the turn singles and windshield washers work. The linkage appears to be in good condition. I do not know where the noise is coming from but I suspect that to be the problem part. Maybe there is another componet in between the multifunction switch and the motor that is bad? Any information would be greatly appretiated. Thank you!

Last edited by Fordracer302; 12-02-2007 at 11:53 AM.
Reply With Quote
+ 0 -
Old 12-02-2007
Needforspeed3685's Avatar
I am: Tim Martin
Join Date: Aug 2005
Location: Lowell, AR
Vehicle: 2000 Ranger Sport 2.5 2wd
Posts: 1,836
Total Props: 2
Sounds like the wiper motor relay is bad. This is what is "clicking", although a click is present during normal operation. I believe the wiper motor relay is behind the driver's side knee-board, but I'm not certain on your year model. Check your owner's manual for the location.
Reply With Quote
+ 0 -
Old 12-02-2007
My91Ranger's Avatar
iTrader: (1)
I am: Rob H
Join Date: Apr 2007
Location: Roseville, Michigan
Vehicle: 1990 Ford Ranger
Posts: 2,252
Total Props: 2
I had a similar problem on my 90. I pulled off the entire turn signal/ wiper blade switch. It has a large wire connecter. For me some of the wires had come loose from the wire connecter and I also cleaned out the turn signal arm with a dielectric spray and terminal cleaner. That completely fixed the problem for me.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 ranger turn signals won't work! v6 4x2 all other lights and wipers work not fuse? kappesdeb General Technical & Electrical 0 07-17-2014 11:45 AM
my windshield wipers wont work i need help Mogley General Technical & Electrical 9 07-21-2010 08:36 PM
pitted winshield help MonsterGuy Auto Detailing 101 10 01-21-2007 07:48 AM
Removing a full decal from winshield as well as from the side of the truck 03RangerInROC Auto Detailing 101 14 01-12-2007 09:48 AM
FX4 Winshield Sticker armin922 Exterior Semi-Tech 10 10-24-2006 03:40 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 10:09 AM.