96 ranger 3.0 - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Welcome to Ranger-Forums! Arrow Member Introductions

Member Introductions New to Ranger-Forums.com? Please take a moment and introduce yourself.

LinkBack Thread Tools Search this Thread
Old 02-13-2015
Thread Starter

I am: rayray ray
Join Date: Feb 2015
Location: memphis, tn.
Vehicle: 1996 ranger ranger
Drive Type: 4x2
Engine: 3.0
Posts: 2
Total Props: 0
96 ranger 3.0

it starts, idles for a min. then just dies. got fuel pressure about 40 psi w key on engine off and above 30psi running. it boggs out when tryn to give it any gas. any suggestions?
Reply With Quote
+ 0 -
Old 02-13-2015
97rangerstepside's Avatar
I am: Jeff
Join Date: Nov 2014
Location: WA
Vehicle: 1997 Ford Ranger
Drive Type: 4x2
Engine: 2.3
Posts: 29
Total Props: 0
Welcome, is the cel on and have you pulled any codes?

Sounds like the maf and IAC need cleaned or replaced.
Reply With Quote
+ 0 -
Old 02-14-2015
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,733
Total Props: 88
96 ranger 3.0

Duplicate post
If you can't find your post just click on "My Posts" in the tool bar under main banner
Reply With Quote
+ 0 -

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 01:56 PM.