Aye, I'm Jake... Having Truck issues - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Welcome to Ranger-Forums! Arrow Member Introductions

Member Introductions New to Ranger-Forums.com? Please take a moment and introduce yourself.

LinkBack Thread Tools Search this Thread
Old 02-13-2016
Thread Starter

I am: Jake
Join Date: Feb 2016
Location: Austell Ga
Vehicle: 1995 Ranger
Drive Type: 4x2
Engine: 2.3
Posts: 1
Total Props: 0
Aye, I'm Jake... Having Truck issues

Gotta 95 Ford ranger 2.3 Liter, I recently installed a clutch. Now having other issues.

#1 Truck gauge for temperature use to always stay on cold. Now it move fluctuations depend on #2.

#2 Radator reservoir top pops and Antifreeze going somewhere have to add antifreeze about everytime the temperature reads halfway or better.

#3 I changed the the thermostat today, think was bad because symptoms above. Problems still accurring

Someone please Help!!!!
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hey guys Jake here. . Jakethesnake Member Introductions 8 12-17-2011 10:39 PM
My '73 Charger build (For Jake) HAZZARDJOHN Project Logs 26 09-12-2008 06:54 PM
Having some very strange reving issues?? Letha 2.3L & 2.5L I4 Tech 8 05-16-2007 09:08 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 12:39 PM.