New to forum - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Welcome to Ranger-Forums! Arrow Member Introductions

Member Introductions New to Please take a moment and introduce yourself.

LinkBack Thread Tools Search this Thread
Old 07-14-2014
Thread Starter

I am: Monty Lynch
Join Date: Mar 2012
Location: Dayton, ohio
Vehicle: 1999 Ford Ranger
Posts: 1
Total Props: 0
Icon7 New to forum

Hello everyone, I have a '99 ext cab stepside that I bought new, still looks good though I don't have any pics to post yet. Recently added a center console and some power leather seats out of an Eddie Bauer Exploder. But the thing I really want to stress in my first post is a sincere THANK YOU to all you good folks on here that posted videos and how to's on replacing the camshaft synchronizer on the 3.0 motor. I was completely unaware that these things caused engine failures and I had 84k on my truck when I saw what everyone was saying about it I almost had a seizure. Needless to say this past saturday I installed a new Motorcraft Synchro and a position sensor. The tutorials made it better. I am a professional industrial mechanic (forklifts, almost 30 yrs now) and that job was not one I look fwd to doing again anytime soon. Laying across the fender and engine like that is for younger people! But hey it's done, truck fired right up, solid oil pressure, no codes, no driveability issues. I am pleased. Thanks again to ALL who posted info on this topic~you most likely saved me an engine~ Pics to follow soon.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
New to the Forum...New to Rangers 01rangerstang03 Member Introductions 11 06-15-2010 09:03 PM
New to this forum but not new to Rangers Old97 Member Introductions 16 11-01-2009 03:11 AM
New Ranger, new to the forum, old Ranger fan... talon63 Member Introductions 13 07-07-2008 10:11 AM
Not sure if this is the right forum... problem with forum Wowak Ranger-Forums Office 6 08-04-2004 01:13 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:00 AM.