1995 Ranger 2.3l WIERD A/C issue. - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 08-31-2013
Thread Starter

I am: Richard Green
Join Date: Mar 2011
Location: Brandon, MS
Vehicle: 1995 Ford Ranger
Posts: 1
Total Props: 0
1995 Ranger 2.3l WIERD A/C issue.

Well, my '95 ranger used to have the coldest A/C of any vehicle I've ever driven, it's r132 not r12. A few months ago, it inexplicably stopped working. I checked the pressure, and it was perfectly fine. I suspected the High or low side pressure switches were bad, so I jumped them, and still couldn't get the compressor to kick on at all. I then wired 12v directly to the compressor, and that did the trick! Instantly started shooting snowballs out of my vents. Plugged everything back together, and it was back to not working. I left it like this trying to find a reasonable a/c mechanic, and stopped fussing about it and just dealt with the heat. Until just the other day....

Now, when I first start my truck, the A/C will blow cold and hard, and will remain that way until I start moving. I can drive up through the gears to third, and by then it's tepid. I can then stop, shut the engine off and restart it and it will be back to blowing cold again. I am at a loss here....
Reply With Quote
+ 0 -
Old 03-10-2016
I am: Ryan Stealey
Join Date: Dec 2015
Location: Lawrenceville, GA
Vehicle: 2000 Ford Ranger
Drive Type: 4x2
Engine: 2.5
Posts: 12
Total Props: 0
compressor clutch may be worn out. are you the only owner? the pag oil in the system normally keeps the compressor from wearing out so fast, a lack of it may cause excessive wear. if the compressor is working like it should right now, and you still get tepid air, may be evaporator freeze up. those are a couple of possibilities.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
wierd sputtering and starting issue Mcgver 4.0L OHV & SOHC V6 Tech 2 02-04-2012 07:07 AM
Wierd issue..idle dixie_boysles 4.0L OHV & SOHC V6 Tech 13 12-02-2011 01:13 PM
1995 mustang seats in a 1995 ranger super cab nyranger95 Interior Semi-Tech 1 06-23-2011 05:50 AM
Will a bumper off of a 1995 Explorer fit a 1995 Ranger? lownslow95 Exterior Semi-Tech 7 11-05-2009 09:42 AM
Wierd Fuel issue mlw20lu 2.9L & 3.0L V6 Tech 19 10-20-2009 07:45 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 12:22 AM.