94 Ranger 2.3L Stalls - Scanner Codes - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 04-25-2011
Thread Starter

I am: chris jones
Join Date: Apr 2011
Location: anytown,USA
Vehicle: 1994 Ranger 2.3L
Posts: 3
Total Props: 0
94 Ranger 2.3L Stalls - Scanner Codes

Hello all, looking for some ideas/knowledge.

94 2.3l

Truck will not idle, it will just stall out. If you hit the gas I can keep it running, but it doesn't sound/feel right. About a year ago the timing belt broke, and I replaced it and it ran OK since then. I recently replaced plugs and wires hoping that would help, but didnt. The plugs looked clean.

I used a Actron code scanner, and the KOEO code was 159 - (That was my fault, forgot to plug the MAF sensor back in, but that didnt help)

Then I got alot of continuous memory codes as follows:

157 - MAF too low
158 - MAF too high
172 - HEGO sensor - voltage indicates lean
211 - PIP sensor fail
214 - Cylinder ID sensor fail
224 - Primary Circuit Fail in Coil 1,2,3 or 4
332 - Insufficient EGR flow

o try the KOER test, I just wedged a bolt on the throttle just enought to keep it running and according to the scanner book, I should get a Engine ID code first, but all I get is code 998 and 224 right away.

998-Engine Control system operating in Failure Mode and Effects Management (FMEM) programming strategy

224 - Primary Circuit Fail (like above)

Where do I begin?
Reply With Quote
+ 0 -
Old 04-27-2011
I am: Marcus s
Join Date: Apr 2011
Location: portage la prairie, mb
Vehicle: 1997 ford ranger
Posts: 2
Total Props: 0
are you sure you have it timed right?
Reply With Quote
+ 0 -
Old 04-28-2011
I am: Bill V
Join Date: Apr 2011
Location: Media PA
Vehicle: 1994 Ford Ranger
Posts: 7
Total Props: 0
i had a similar problem the motor was cranking but it wouldn't start i don't remember the codes but it was for the ignition control modular and coil pack so i got a new ignition control modular and it helped but i still want to get new coil packs because the stock packs for 94 suck and go bad easy
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Codes and Codes fraser19 General Ford Ranger Discussion 0 06-14-2013 02:14 PM
CODES CODES- IDLE issue supraboatguy General Technical & Electrical 1 11-08-2011 01:17 AM
1995 E350 stalls while idling... this truck NEVER stalls. Ever..??? FMD General Ford Discussion 0 04-06-2010 04:19 PM
Scanner antenna for capped Ranger Pyrofallout General Technical & Electrical 14 06-05-2009 01:07 PM
OBD II CODES- for those without a scanner davidw General Ford Ranger Discussion 8 11-17-2008 04:12 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 10:41 PM.