97 2.3 wont start has fuel spark and air ? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 05-19-2012
Thread Starter

I am: joe nigro
Join Date: Nov 2010
Location: corbin,ky
Vehicle: 1996 ford ranger
Posts: 3
Total Props: 0
Icon5 97 2.3 wont start has fuel spark and air ?

Ive read alot of posts but i am still hunting and need some helpful ideas I have a 97
2.3l auto 4r44e this started out with PO7003 code i believe it said it was a stuck 2-3 solenoid and truck was missing 3 gear but i changed solenoid and di valve body upgrades when done it still did same thing, however thats not the problem so i run out of time to work on that problem so i parked it for a month when i went to start it it would not dtart so i checked spark it had spark between plug and plug wire im not sure how strong it is however i then checked fuel took bed off checked pump, it ran , then checked pressure on the rail it had 37 PSI, so then i shot ether in it and it ran a short time but i read ore and thought maybe crank positoning sensor which i ma currently changing now however i read more and am gettting confused and desperate im not well versed on all the electronics anymore im kinda old school, i am now freaking out thinking if this isnt it could it be cam sensor ? or even pcm or eec or ignition coil but it had spark and ran with ether but im starting to chase my tail here, so im trying to give the info i know for people better experienced to give some ideas or help if they would sorry this so long i was trying to set the scenario up accurately if any more info needed ill gladly supply it if i can, help would be appreciated, i guess im thinking pcm eec , or whatever theyre called now days and wondering if its not my problem from the beginning with trans and now this starting problem i dont know what kind of problems these sensor can cause. thanks in advance
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 4.0 wont start very intermittent spark 9440a4ld General Technical & Electrical 1 09-02-2014 11:12 AM
99 Ranger: engine wont turn over, has power, and no check engine light sprx26 General Technical & Electrical 1 03-19-2014 11:07 AM
New fuel pump, filter, inertia switch, still wont start. akathechef 2.9L & 3.0L V6 Tech 3 08-16-2013 06:48 AM
truck wont start... has fuel and spark.. help?? danger_ranger93 2.9L & 3.0L V6 Tech 2 08-03-2012 06:08 PM
Help!! windows wont roll up and deck wont come one dantheman General Technical & Electrical 4 08-26-2010 06:33 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:09 AM.