97 Ranger, emissions readiness problem - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 03-27-2012
Thread Starter

I am: J P
Join Date: Mar 2012
Location: GA
Vehicle: 1997 Ford Ranger XLT
Posts: 13
Total Props: 0
I bypassed it Rev, i just couldnt find any pinches or exposed wire but i did look for a while...

the water that comes out of the tailpipe is only right at 1st in the morning and it does go away immediately and then the steam is gone by the time i pull out of the complex parking lot.

I did find that info earlier on P0420...so what should i try 1st, the cheapest part like O2 sensor or just go for having cat replaced off the batt
Reply With Quote
+ 0 -
Old 03-27-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
I am: J J
Join Date: May 2005
Location: San Diego, CA
Vehicle: 2001 Ranger Edge
Posts: 1,179
Total Props: 18
I know this is going to sound redundant but, you know you had a short in the main harness to the PCM. That harness contains all the input/output wiring to the PCM to include the O2 sensors. If you still have other effected wiring within that harness you will eventually have to track it down and fix it to remedy the current problem or at least eliminate that as a potential source. Otherwise you'll just wind up throwing parts in that you really don't need and wont fix the problem.
Reply With Quote
+ 0 -
Old 03-27-2012
I am: Larry Spitzer
Join Date: Feb 2012
Location: Windsor, WI
Vehicle: 97 Ford Ranger
Posts: 93
Total Props: 1
I had a P0420 on a Windstar 3.0 engine and found that the sensor was lazy. Replaced the precat 02 sensor and have not had the problem since.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
P1000 I/M readiness not complete code? myersth 2.9L & 3.0L V6 Tech 7 04-22-2012 02:59 PM
emissions readiness test TexasRanger General Ford Ranger Discussion 0 02-26-2009 01:56 PM
Emissions evan.hills 4.0L OHV & SOHC V6 Tech 32 11-22-2008 05:14 PM
California Emissions? ericm98 4.0L OHV & SOHC V6 Tech 13 05-31-2008 09:17 PM
glasspack & emissions LowMaz 2.9L & 3.0L V6 Tech 10 02-06-2007 07:02 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 01:49 PM.