backfire from intake - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 11-20-2013
Thread Starter

I am: Mario Carlin
Join Date: Jun 2013
Location: lake havasu
Vehicle: Ford Ranger
Posts: 1
Total Props: 0
backfire from intake

I have a 93 ford ranger.. I pickex this truck up about 6 months ago.. when I first got it I changed the oil spark plugs air filter and timing belt. It ran awsome for the first 3 months the all of a sudden it died on me.. so then ireplaced the fuel filter fuel pump and radiator, I changed the radiator cuz of rust. The truck ran ok for a coup, e more weeks after that but then it started to hesitate and backfire through the intake. I ran a comp on it and it through theses codes.. o2 temp sensor idle air control valve and maf sensor.. I replaced all of those brand new. The weird thing is thoughin the last 3 months it would run fine for a week then be down for two.. it did this off and on for the last 3 months. I just put the iacv in today since all those sensors are really expensive so I did it a lil at a time. Now that i just replaces I iacv it still backfires through the intake.. the truck wont even idle right and takes forever for it to even start and when it dose I have to pump the throttle to get it to berley idle. At this point I have no idea what it could be or what could cause this. I cant even run a test on it cuz it wont stay ildeling l8ng enough to throw any codes. So what my question is where do I go from here, what kind of things could cause it to backfire from the intake? I am really confident that the timing is set right since I did that over 6 months ago and it ran perfect for about 3 months befor it showed and hesitation and just died on me. And what really has me confused is why would it just decide to run good for a week or two and decide to just quit on me when it wants to.. any kind of feed back would be greatly appriciated! If their is anything else you would need to know just ask and ill try to answer it to the best of my knowlage. Im a pretty decent mechanic not the best but I know my way around and engine.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Acceleration Hesitation and Intake Backfire RangerBuff 4.0L OHV & SOHC V6 Tech 4 03-26-2015 06:47 PM
Knocking (backfire) in Intake? I'm stumped! jharrellh 4.0L OHV & SOHC V6 Tech 5 12-10-2014 10:10 AM
how do i troubleshoot carburetor backfire, exaust backfire, and acceleration issues corey1991 SOHC - 2.3L & 2.5L Lima Engines 2 10-15-2010 04:26 PM
Intake Manifold Gasket/Intake Manifold fordboston 4.0L OHV & SOHC V6 Tech 6 01-25-2010 09:37 PM
Composite intake and aluminum intake differences Toreador4x4 2.9L & 3.0L V6 Tech 8 07-16-2009 09:34 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 07:56 PM.