Fun With Purge Valves and CELs - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 02-25-2014
Blossomforth's Avatar
Thread Starter

I am: Blossom Forth
Join Date: Feb 2014
Location: CT
Vehicle: 1996 Ford Ranger
Drive Type: 4x2
Engine: 2.3
Posts: 39
Total Props: 0
Fun With Purge Valves and CELs

Alright, so i've been battling a CEL for the past few weeks and i wanted to run the whole process past you guys and see what else i should do.

Originally it threw the CEL and returned a P1443 code, which is a purge valve failure of some sort... i forget the exact thing. Anyway, i googled the issue and most sources say its either a leak in the system or a bad purge valve/sensor. Starting with the cheapest option, i replaced all the rubber lines. No change. Changed the solenoid, same thing... no change. However the light was out for about 90 miles before i came back on. Next i replaced the sensor, and the light was out for one starting cycle. After reattaching the battery and driving, it returned when i started the truck again.

Sunday afternoon i was replacing my rear window in my garage and noticed the faint smell of gas lingering in the garage, so i know i stlll have a leak somewhere. Where should i go from here?

The truck is a '96 2.3L. About 178k on it. Im also getting about 17-18mpg through mixed city/highway driving, so maybe that is could be another clue as to whats causing my problem.

Oh gurus of all things Ranger...where should i go from here?
Reply With Quote
+ 0 -
Old 02-26-2014
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,749
Total Props: 88
If you smell gas then that would be the issue, the EVAP system(what you are working on), relies/assumes an air tight system.
That includes the gas tank, which is the focus of the EVAP system, it's mission is to not allow gas fumes out of the tank.

So a loose or bad gas cap, or a broken/cracked filler or vent tube can cause EVAP system to fail tests.

Locate the smell and you will locate the problem.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Canister Purge Solenoid/Flow Sensor Replacement briz SOHC - 2.3L & 2.5L Lima Engines 17 01-21-2015 11:44 AM
Valves bad and Head Gasket Bad 2005 Ranger 4.0 Ranger093 4.0L OHV & SOHC V6 Tech 25 02-06-2011 10:48 PM
Canister Purge Valve jtfoxman 4.0L OHV & SOHC V6 Tech 8 09-16-2008 11:03 AM
Brake help, residual valves, disc brakes, no abs, and prportioning valves... zabeard General Technical & Electrical 5 02-23-2007 12:33 PM
canister purge solenoid cap??? loneFX4 4.0L OHV & SOHC V6 Tech 2 07-14-2005 06:58 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 08:27 PM.