No Heat, Help - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 02-13-2013
Cobra GT's Avatar
Thread Starter

I am: James Taylor
Join Date: Dec 2008
Location: Metairie, La.
Vehicle: 1993 Ford Ranger
Posts: 5
Total Props: 0
No Heat, Help

I changed the water temp sending unit because my gauge was not working and the engine coolant temp sensor and still have no heat. Also the sending unit did not fix my gauge problem, any thoughts? I took out the heater core to see if it was completely clogged and it wasnít the blower and A/C work. just donít know why I have no heat .This is the strangest thing. I guess the thermostat could be bad, please help, thanks: sad:
Reply With Quote
+ 0 -
Old 02-14-2013
sheltonfilms's Avatar
I am: Anthony Shelton
Join Date: Apr 2010
Location: Knoxville, TN
Vehicle: 2000 Ford Ranger
Posts: 622
Total Props: 6
Wouldn't happen to be a 2.3L 4 banger would it? Those have been known to show gauge problems when the water pump impellers are rotted away. Reason the gauge shows weird is the way that the sensors are set up.
Reply With Quote
+ 0 -
Old 02-14-2013
Pauly91's Avatar
I am: Paul Owen
Join Date: Nov 2011
Location: Big Lake, MN
Vehicle: 95 Ford Ranger
Posts: 11
Total Props: 0
I would Check the thermostat. I have run into problems with the ford gauges staying on C when the thermostat was bad. Because most gauges fluctuate between a certain temp range. If the minimum temp isn't reached because the thermostat isn't doing it's job the gauge will read cold. That also can explain your lack of heat.
Reply With Quote
+ 0 -
Old 02-17-2013
Mikev69's Avatar
I am: Mike V
Join Date: May 2010
Location: O'Fallon, mo
Vehicle: 1997 Ford Ranger
Posts: 32
Total Props: 0
Lack of heat? you mentioned A/C and blower work, Does your blend door? had to replace mine,and the actuator.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heat blower stopped, then started, now stopped heat works nanookc General Technical & Electrical 4 02-17-2015 01:18 PM
need help heat is out sgalka91 General Ford Ranger Discussion 2 11-27-2009 01:19 PM
Help - Wiring Seat Heat Problems FullThrottle02 General Technical & Electrical 4 08-16-2008 08:20 AM
Heat Removal - Help! sawred New Ideas 14 07-12-2005 10:24 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:24 AM.