Weird problem. Need help bad. - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 01-21-2016
Thread Starter

I am: Alexander Fowler
Join Date: Jun 2014
Location: Dalton, GA
Vehicle: 1997 Ford Ranger
Drive Type: 4x2
Engine: 2.3
Posts: 1
Total Props: 0
Weird problem. Need help bad.

Okay, so a couple days ago two of my speakers went out on my 98 xlt 4 cylinder. Then the wipers stopped, the same day the truck died on me. Borrowed my grandpa's ram 1500 for a day and put a new alternator on it since the battery is 2 months old. If I jump it off it will run and drive fine for about 10-15 minutes then it'll die again. I don't think it's the battery and I put a brand new alternator in today. I don't know what's wrong and I don't want to have to push it out of another interesection. The truck is right under 260,000 miles and I wanna keep her running. Any ideas guys?
Reply With Quote
+ 0 -
Old 01-21-2016
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,739
Total Props: 88
Buy/get a volt meter and save yourself some money.

Why do you think any of what you described has anything to do with the battery or alternator?

New battery should read 12.5volts or higher, with engine off
With engine running battery voltage should read 13.5volts or higher, but no higher than 15volts.
With engine running turn on head lights and set heater fan to High, battery voltage should stay above 13.5volts

If that's what you get then battery and alternator are fine.
If not then you have blown fuse or bad fusible link

In the engine fuse box, find the Alt Sys Fuse, 30amp, check it
On the outside of this fuse box is a 175amp MEGA Fuse, check it

Does the battery light come on when you turn on the key?
It should, if not check Fuse #15 7.5amp in cab fuse box

1998 Ranger had 4 speakers and you said 2 quit working, all 4 run off the same amplifier so this is not a 12volt battery power issue.

Wipers have their own fuse, have you checked it?
#16 30amp in cab fuse box
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help - 5 bad codes. Could it be just bad computer? mrsquirrels General Technical & Electrical 7 06-27-2012 06:50 PM
Weird problem I need help diagnosing IcecreamLtDan General Technical & Electrical 7 03-06-2008 03:01 AM
The_Dealer: Bad Deal Bad Member Bad Sell! LayingFrame89 Ranger Products, Company, & Member Reviews 34 12-01-2007 06:59 AM
Stock Drivesaft with RCD = BAD BAD BAD PICS INSIDE ranger General Ford Ranger Discussion 32 07-31-2007 11:50 AM
ALL offroaders are BAD BAD BAD! FMD General Ford Ranger Discussion 13 04-25-2006 07:21 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 12:57 AM.