Leaf Spring Out-of-Alignment (Normal)? - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow Suspension Tech

Suspension Tech General discussion of suspension for the Ford Ranger.

LinkBack Thread Tools Search this Thread
Old 06-22-2013
Thread Starter

I am: Sal Palantonio
Join Date: Jan 2013
Location: Portland, ME
Vehicle: Ford Ranger
Posts: 8
Total Props: 0
Leaf Spring Out-of-Alignment (Normal)?

Good morning all. As you can see from the pictures the bottom spring is out of alignment by about half an inch or so. Is this relatively normal (the vehicle has 110,000 miles on it) wear on a vehicle or a sign of something much worse?




Attached Thumbnails
Leaf Spring Out-of-Alignment (Normal)?-93af60ca-2040-4feb-bbef-3d9238355ee3-2162-000005abbf2e2dd4_zps3399cade.jpg   Leaf Spring Out-of-Alignment (Normal)?-92e11cd0-035f-413a-9a3d-760b42c09942-2162-000005abcba2128a_zps32fdbba4.jpg  
Reply With Quote
+ 0 -
Old 06-23-2013
Scrambler82's Avatar
Old Guy Userů ltr

iTrader: (12)
I am: Grev B
Join Date: Jul 2009
Location: SoCal
Vehicle: 2003 Ford Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 6,627
Total Props: 10
Two thoughts, first is easiest, lose U-Bolts holding the rear axle to the springs, second is a broken spring.

If you are replacing a broken spring check out the spring hangers in the rear of the vehicle, chances are they are either rotted off or close to it and replace them both.
Reply With Quote
+ 0 -
Old 06-26-2013
The S-10 Killer's Avatar
I am: Lucas Gauthreaux
Join Date: Aug 2008
Location: BR, LA
Vehicle: 1999 Ford Ranger
Posts: 646
Total Props: 3
is it kicked out 1/2" on the opposite side?
Reply With Quote
+ 0 -
Old 07-25-2013
jimehat112's Avatar
I am: Robert
Join Date: Aug 2006
Location: Amarillo, Texas
Vehicle: 2003 Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 41
Total Props: 0
must not be that uncommon

I have the exact same situation on my ranger, been like that since I bought it, haven't bothered to fix it, and hasn't broken or caused any problems that I can tell. bottom spring is kicked out to one side just as shown.
Reply With Quote
+ 0 -
Old 07-26-2013
I am: paul brown
Join Date: Mar 2010
Location: santa rosa, ca
Vehicle: 2002 2WD ranger
Posts: 63
Total Props: 0
I had my leafs apart, that flat bottom "spring/plate" is only attached to the upper springs via that center bolt that sits in the axle perch. just hammer it back in alignment and check all the mounting points to be sure nothing is broken. p.s. i can't tell by the photos but are the leafs lined up nicely directly above the axle?? check the center bolt and make sure the nut is present.

Last edited by kalifornia; 07-26-2013 at 12:17 PM.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Explorer leaf springs vs. Sport Trac leaf springs PUNKROCKPILOT Suspension Tech 53 03-14-2014 10:17 AM
taking out a rear leaf spring Ocranger91 Suspension Tech 5 02-15-2011 04:04 AM
I cant get front leaf spring bolt out. help!!!! Downey Suspension Tech 42 03-12-2010 09:39 AM
Leaf spring mount breakage... normal? Cody_288 General Ford Ranger Discussion 12 03-20-2007 04:40 PM
Add-A-Leaf or helper spring roro72 Suspension Tech 6 07-28-2005 05:58 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 11:08 AM.