Body lift --> Check Engine Light... - Ranger-Forums - The Ultimate Ford Ranger Resource


1" & 3" Body Lifts General discussion of body lifts for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-29-2007
Snowboard101's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: CT
Posts: 130
Body lift --> Check Engine Light...

I've had my body lift on my truck now for about two weeks now and I've really enjoyed it, except that my check engine light is on now... The truck makes no weird noises, or does anything not normal, but that check engine light has been on since I installed the lift... I'm hoping it's nothing terrible, but I'm bringing it in to the mechanic soon. Has anybody else had this, or know what it could be?
Reply With Quote
  #2  
Old 04-29-2007
Member
 
Join Date: Aug 2006
Location: Pensacola, FL
Posts: 647
How many miles since you last changed your oil? Mine threw a CEL cause I was a little late on my oil change and it was good to go. The turds at the Jiffy-Lube tried to tell me it was the gas cap (but there's a seperate light for that). If your oils good, run it up to autozone and get the code from them.
Reply With Quote
  #3  
Old 04-30-2007
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
Yea....don't dump $40 for somebody to pull the code. Go to Autozone, they do it for free. Might just be something stupid....like a $15 sensor,
Reply With Quote
  #4  
Old 04-30-2007
whiteo5xlt's Avatar
Member
 
Join Date: Nov 2006
Location: wilmington ma
Posts: 279
when you did your body lift did it come on after it or a week after it you might have forgot to plug back in something or check the ground extenders snd make sure there tight.
Reply With Quote
  #5  
Old 04-30-2007
gatorblue92's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Delaware
Posts: 8,238
i would bet that something came loose during the lift install and just finally came off like a o2 sensor connector
Reply With Quote
  #6  
Old 04-30-2007
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
Quote:
Originally Posted by gatorblue92
i would bet that something came loose during the lift install and just finally came off like a o2 sensor connector
Exactly what I was thinking.
Reply With Quote
  #7  
Old 04-30-2007
Member
 
Join Date: Nov 2005
Location: Avon, IN
Posts: 756
Quote:
Originally Posted by Oh5Edge
How many miles since you last changed your oil? Mine threw a CEL cause I was a little late on my oil change and it was good to go. The turds at the Jiffy-Lube tried to tell me it was the gas cap (but there's a seperate light for that). If your oils good, run it up to autozone and get the code from them.

an idiot light for the gas cap? since when?
Reply With Quote
  #8  
Old 04-30-2007
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
why not pull the code or have it pulled for you to determine what the problem is

could be something not related to the body lift.........
Reply With Quote
  #9  
Old 04-30-2007
Member
 
Join Date: Aug 2006
Location: Pensacola, FL
Posts: 647
Quote:
Originally Posted by Big04Ranger
an idiot light for the gas cap? since when?
I got one in my 05. You can see it but I've never really tried to actually light it up.
Reply With Quote
  #10  
Old 04-30-2007
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by Oh5Edge
How many miles since you last changed your oil? Mine threw a CEL cause I was a little late on my oil change and it was good to go. The turds at the Jiffy-Lube tried to tell me it was the gas cap (but there's a seperate light for that).
There is no CEL or DTC for a late oil change.

However, there is one for a "gross leak" in the evap system. The "Check Fuel Cap" light or icon comes on first when the tank fails the leak test. This is to alert the driver to a possible loose or missing fuel cap. If the problem isn't corrected in the next two drives, the CEL will light and a trouble code will be stored.

Quote:
Originally Posted by Big04Ranger
an idiot light for the gas cap? since when?
Since 2001, IIRC. 2001~2003 have a light with the words "Check Fuel Cap" and 2004~2007 have an icon.
Reply With Quote
  #11  
Old 04-30-2007
Snowboard101's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: CT
Posts: 130
Funny you ask about the oil because I had changed it less than a week before the body lift and it wasn't driven much between the oil change and the BL...

As for when did it light up? The light came on within the hour of test driving it after the body lift was installed.

I'll be bringing it to autozone soon to get the code and we'll see what it is... hopefully something easily fixable, the body lift was enough work already...

**also, I heard that the rubber fuel replacement tube that comes in the PA kit, may cause the CEL to go on... but if that's the case, I think a lot of people would have the same problem as me
Reply With Quote
  #12  
Old 04-30-2007
Du510's Avatar
Member
 
Join Date: Dec 2006
Location: Northeast
Posts: 229
I'd suggest to check all the vacuum lines too...
Reply With Quote
  #13  
Old 04-30-2007
whiteo5xlt's Avatar
Member
 
Join Date: Nov 2006
Location: wilmington ma
Posts: 279
i can bet that something came loose or unclipped during the lift so i would check that
Reply With Quote
  #14  
Old 04-30-2007
04 EDGE
Unregistered User
 
Posts: n/a
mine came on shortly after the BL install also.

it was the large EVAP system line under the master cylinder area. the hose was stretched and pulled itself off the metal pipe. therea a quick connect type fitting on one end and the other end just slides over the metal pipe. all i did was bent the line a tad and used a few hose clamps to secure it.
Reply With Quote
  #15  
Old 04-30-2007
Member
 
Join Date: Apr 2006
Location: Paulding , GA.
Posts: 1,435
mine came on also when i got mine done so i took it to ford thinking it was warranty nope it was that the little extra peice of fuel line they give you with the kit for the over fill line. the cupling (sp?) was not tight enough so i had to run it down a little more and retighten the fastners and reset it
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Check Engine & Check Pants! Brian5792 4.0L OHV & SOHC V6 Tech 2 07-21-2014 04:24 PM
99 Ranger: engine wont turn over, has power, and no check engine light sprx26 General Technical & Electrical 1 03-19-2014 12:07 PM
o/d light, check engine light and rough idle wtf man 2.9L & 3.0L V6 Tech 8 02-23-2014 01:39 PM
problem with engine and check engine light warner.325 SOHC - 2.3L & 2.5L Lima Engines 5 12-09-2009 04:48 AM
spedometer out + ABS light + check engine light joey v General Technical & Electrical 13 06-17-2008 08:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.