Help Wanted: BL installation Sat/Sun Nov.14-15 - Page 3 - Ranger-Forums - The Ultimate Ford Ranger Resource


1" & 3" Body Lifts General discussion of body lifts for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #51  
Old 11-16-2009
Hitch's Avatar
Member
 
Join Date: Nov 2006
Location: OH
Posts: 401
Hey listen, anybody around tomorrow, come on down. We can use the help, and im sure pizza can be arranged!
Reply With Quote
  #52  
Old 11-16-2009
sullys_ranger's Avatar
Member
 
Join Date: Mar 2006
Location: NewLexington, Ohio
Posts: 3,615
I did one side at a time with a jack and come wood blocks
Reply With Quote
  #53  
Old 11-16-2009
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
Damn it iwshi woulda saw this earlier.. I was off today i coulda cruised down....
Reply With Quote
  #54  
Old 11-16-2009
MudSlanger's Avatar
Member
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
How are you having such a hard time with this? Its a very easy process lol... Did you happen to look online for directions on how to do it?
Reply With Quote
  #55  
Old 11-16-2009
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
Quote:
Originally Posted by MudSlanger View Post
How are you having such a hard time with this? Its a very easy process lol... Did you happen to look online for directions on how to do it?
Truthfully the directions that come with it seemed to work really well for me.... They seem really detailed..
Reply With Quote
  #56  
Old 11-16-2009
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
where are the pics
Reply With Quote
  #57  
Old 11-16-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Akron
Posts: 61
on the cameras memory card that is in the shop.... I will get some up when we are done. We have only invested 6 hours total into the thing. 2 of which I was by myself taking the bumpers/towhooks and installing the shift extension and extending the gas filler. the other 4 hours were dedicated to lifting the bed re-installing the rear bumper and pulling the jump seats out. So really we arent doing too bad. Being as though I never really done a whole lot with working on vehicles my lack of knowledge about finding the ground straps and what to do exactly with the radiator...I started this thread to get help because...well like ive said before Im a noob haha. We should be able to get it lifted the rest of the way tomorrow night. pizza for all who help. we are meeting at 7pm and will likely go till 10 or so.
Reply With Quote
  #58  
Old 11-16-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Akron
Posts: 61
Mudslanger: I know it may seem like an easy 2 hour project compared to your 3 to 5L conversion but as I have said before I dont claim to be any kind of mechanic or know too much about cars. I can do brakes and exhaust and body work. Im trying to learn and maybe someday it will take only an afternoon to get one of these done. Until then Ill just keep getting on the forum and whinning haha.

Quote:
Originally Posted by MudSlanger View Post
How are you having such a hard time with this? Its a very easy process lol... Did you happen to look online for directions on how to do it?
Reply With Quote
  #59  
Old 11-16-2009
MudSlanger's Avatar
Member
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
If i lived there id help ya but i live way too southwest for that :(
Reply With Quote
  #60  
Old 11-17-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Akron
Posts: 61
I think everything will go fine tonight. Ill keep updating, unfortunately we cant start until about 7..I have work and so does Hitch (Chuck) I have sullys number so ill just have to call him if we run into anything.
Reply With Quote
  #61  
Old 11-18-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Akron
Posts: 61
Well it is wednesday morning 2:20am. Chuck came at 7pm tuesday and we got the truck lifted. Me and my buddy decided we were going to stay and get it all done. Once we re attatched everything the moment of truth. We tried to start the truck and nothing. The lights, radio, gages, and windows all work but the engine did not even try to turn over. One single click is all it makes when you turn the key...I am baffled and really need help to what may have caused this to happened and more importantly how to fix it. The truck looks great but until I hear it roar I am heart broken. Please Help!!!
Reply With Quote
  #62  
Old 11-18-2009
93rangerXLT4x4's Avatar
Member
 
Join Date: Aug 2009
Location: Salmon Arm BC
Posts: 959
pinched wire?? did you wiggle the battery terminals on the post?? might just be a connection problem.
Reply With Quote
  #63  
Old 11-18-2009
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
Yeh deffintley check your wires to your battery and starter thats what it sounds like....
Reply With Quote
  #64  
Old 11-18-2009
cchsbuzz19's Avatar
Member
iTrader: (5)
 
Join Date: Jul 2007
Location: North Canton, Ohio
Posts: 2,417
Sorry I couldn't come out last weekend. Not really sure why the truck wouldn't start, Most likely a pinched wire like they said.
Reply With Quote
  #65  
Old 11-18-2009
Hitch's Avatar
Member
 
Join Date: Nov 2006
Location: OH
Posts: 401
Josh, remember when we added the steering extension we moved the big bundle of wires? CHeck that plug and make sure its bolted back down. If thats loose, which it prolly is, that is why it won't start.
Reply With Quote
  #66  
Old 11-18-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Akron
Posts: 61
Ok I know exactly what youre talking about. I hope that is it because to reply to everyone else: The radio, headlights, windows, ect ect all work. But like I said nothing happens when you turn the key soo...Ill have to check that around 4 o'clock when I get out of class. It was very frustrating when we decided to stay and get everything back together and then to have that happen....
Reply With Quote
  #67  
Old 11-18-2009
Hitch's Avatar
Member
 
Join Date: Nov 2006
Location: OH
Posts: 401
so everything is together? Sweet! Check that plug. It is a 10mm bolt and thats what holds it together.
Reply With Quote
  #68  
Old 11-18-2009
sullys_ranger's Avatar
Member
 
Join Date: Mar 2006
Location: NewLexington, Ohio
Posts: 3,615
or check the ground wires. Thats the only crappy part of doing a body lift, you gotta keep an eye on every wire and such while lifting the damn thing up.
Reply With Quote
  #69  
Old 11-18-2009
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
Quote:
Originally Posted by Hitch View Post
Josh, remember when we added the steering extension we moved the big bundle of wires? CHeck that plug and make sure its bolted back down. If thats loose, which it prolly is, that is why it won't start.
what in hell did you boys disconnected! there shouldn't be any wires effecting installing the steering extension!
Reply With Quote
  #70  
Old 11-18-2009
seed60's Avatar
RF Veteran
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Don't forget to check the ac hose before you crank it up!!
Reply With Quote
  #71  
Old 11-18-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Akron
Posts: 61
The steering extension was being a butt hole to get on it was very snug to tap it on with a hammer there is a plug that we disconected that we think may be why the engine wont start I thought it was back together but Ill have to check when I get over to the farm tonight. Ill post as soon as I get it figured out. (about 4ish)
Reply With Quote
  #72  
Old 11-18-2009
wellcom2knoxvile's Avatar
Member
iTrader: (2)
 
Join Date: Oct 2007
Location: Corvallis, OR/Seattle, WA
Posts: 1,390
hold up! since the truck hasnt run in awhile, and you probably had the doors open = dome light on, you could have drained the battery! so theres enough juice to turn on the lights and stuff, but not enough to crank it over! all you will hear is a click. have someone jump you or charge your battery. i really suspect that is the answer!??
Reply With Quote
  #73  
Old 11-18-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Akron
Posts: 61
The main computer was not reconnected all the as Chuck (aka Hitch) had stated. I had thought he had reconected it but I was wrong. I just got to the farm snapped and bolted it together and she fired right up!
Reply With Quote
  #74  
Old 11-18-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Akron
Posts: 61
Now all I need is to re-install my jump seats.... and I need some help uploading pictures. I keep getting an "invalid file" error when trying to upload an avatar and dont know the best way to upload mass pictures for you guys to see.
Reply With Quote
  #75  
Old 11-18-2009
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
WINDSHIELD SUN STRIP HELP!!!!!!!!!!! 97blueranger Exterior Semi-Tech 35 07-28-2010 12:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.