acceleration issue - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-10-2008
Member
Thread Starter
 
Join Date: May 2008
Location: king george, va
Posts: 5
acceleration issue

ok well i just got the truck, i changed the plugs and wire....wasnt fun....ok the truck starts right up fine, idles fine, but i have absolutely no power, it will rev fine but soon as i release the clutch it wants to bog down.

Im going to replace the fuel filter here in the next day, but my conclusion is the cat converter.....agree, disagree.....

thanks for the help
Reply With Quote
  #2  
Old 05-11-2008
Member
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
i had a problem like that changed my cat saturday and runs fine. i too did plugs wires and fuel filter
Reply With Quote
  #3  
Old 05-11-2008
Member
Thread Starter
 
Join Date: May 2008
Location: king george, va
Posts: 5
im going for cat this week and was thinking of picking up a fuel filter
Reply With Quote
  #4  
Old 05-12-2008
Member
 
Join Date: Oct 2007
Location: reynoldsburg, ohio
Posts: 34
im also getting a whole new exhaust, and do u think that a fuel filter will be necessary to get all the power back? cuz i wasnt really planning on doing that anytime soon
Reply With Quote
  #5  
Old 05-12-2008
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
I just checked your profile and see you have a 1993.
Just for ***** and giggles , jack up the front tires , one at a tme , and see if they are turning freely.You may have a stuck brake caliper , or two ,which would really make the engine bog trying to move it.
Reply With Quote
  #6  
Old 05-18-2008
Member
Thread Starter
 
Join Date: May 2008
Location: king george, va
Posts: 5
ill do that.....i put a test pipe on it and no difference, so now for the fuel filter
Reply With Quote
  #7  
Old 05-18-2008
Member
Thread Starter
 
Join Date: May 2008
Location: king george, va
Posts: 5
the freakn crank pulley was loose as well, it sounded like a chain rattling.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
trans issue, and i mean issue rangerdanger01 Drivetrain Tech 2 01-09-2011 01:13 PM
Is it a timing issue or a fuel issue? Drewbis SOHC - 2.3L & 2.5L Lima Engines 7 08-13-2010 07:16 AM
Sticking in first on hard acceleration jdugan4859 Drivetrain Tech 2 06-01-2005 08:29 PM
Pinging on Acceleration 00RANGER00 2.9L & 3.0L V6 Tech 11 05-31-2005 04:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:30 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.