Bad Miss - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-28-2008
THEDUSTCLOUD's Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: Huntington, WV
Posts: 44
Bad Miss

Hi,
guys, I have a 1995 Ford Ranger 2.3L 4x4 5speed. It has about 155,000 miles on it and was given to me from my dad. It currently has a real bad miss. I had a computer hooked up to it. Said there was a miss fire in cyl. 3.
I've replaced the plugs about 30,000 miles ago and wires and just replaced the front coil pack. I know the truck needs Oxy sensors. I check the plugs today and the front plugs (closest to the front bumper) were burned up and rusted. Didn't have electrodes or anything. Completely toast. A couple others were just black. and the front right plug cap was gone and dangling. Can anyone tell me if the bad Oxy sensor is causing this? Maybe burning to rich and killing the plugs? What else could it be?
Thanks in advance guys!
Reply With Quote
  #2  
Old 09-28-2008
Member
 
Join Date: Jul 2007
Location: Los Angeles, CA
Posts: 68
Icon7

I don't think bad O2 sensor will cause "bad miss". Tried new DIS. Let us know what the outcome is.
Reply With Quote
  #3  
Old 09-28-2008
THEDUSTCLOUD's Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: Huntington, WV
Posts: 44
Quote:
Originally Posted by 2046fan View Post
I don't think bad O2 sensor will cause "bad miss". Tried new DIS. Let us know what the outcome is.
Isn't a coil pack the distributor?
Thanks!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The_Dealer: Bad Deal Bad Member Bad Sell! LayingFrame89 Ranger Products, Company, & Member Reviews 34 12-01-2007 07:59 AM
Stock Drivesaft with RCD = BAD BAD BAD PICS INSIDE ranger General Ford Ranger Discussion 32 07-31-2007 12:50 PM
after SAS brake issues. advice? did i miss something? zabeard General Ford Ranger Discussion 39 02-21-2007 11:11 PM
ALL offroaders are BAD BAD BAD! FMD General Ford Ranger Discussion 13 04-25-2006 08:21 AM
Engine seems to miss ? crazy wheelerman 730 2.9L & 3.0L V6 Tech 3 02-26-2006 09:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:17 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.