Need Help - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-25-2008
Member
Thread Starter
 
Join Date: Mar 2008
Location: KNOXVILLE, TN
Posts: 1
Need Help

I am having engine problems and wonder if anyone has any suggestions for me.
I was driving my truck sunday and everything was fine, I was running about 35 mph I shifted into 4th and pressed the accelerator and it was like it wasn't getting any gas, I went back to 3rd and as long as I stayed there It ran along at 35mph I managed to get to a safe place to pull off and tried to shift to 4th again, this time the engine died and would not restart. It turns over just fine but does not fire at all. I checked fuel pump (it runs), I changed the filter (didn't help) next I checked the plugs ( I have the 4cyl with the two coil packs and the 8 plugs) I am getting no spark at all from the front coil pack, the rear coil pack will fire but I'm not getting a blue spark, just a weak yellow one. Should I try replacing the coil packs next or is there mabye something else to check first? Any info will be much appreciated.
EL DAVE
Reply With Quote
  #2  
Old 03-26-2008
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
Might be the crank sensor?
Reply With Quote
  #3  
Old 03-26-2008
mossyoak03's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Virginia Beach, VA
Posts: 193
ya i would change out the coil packs to and possibly the plugs and wires depending on the last time it was done.
Reply With Quote
  #4  
Old 03-26-2008
FordRangerXLT's Avatar
Member
 
Join Date: Sep 2007
Location: Fitchburg,MA
Posts: 137
Check your ground cables.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help figuring out what shocks I need Slow94 Suspension Tech 0 06-20-2010 05:51 PM
I need new shocks and i need some help 2007BlackFX4 Suspension Tech 3 06-03-2010 08:36 PM
so i need a sub but i need help finding one... DeMar17 Audio & Video Tech 8 06-10-2009 07:45 AM
NEED HELP!!! need to install new Cd player 01edgeMan Audio & Video Tech 6 01-11-2009 07:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:33 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.