no spark - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-07-2007
Member
Thread Starter
 
Join Date: Jun 2007
Location: shamokin p.a.
Posts: 9
Icon9 no spark

i need help real bad, i blew the head gasket on my 2.3 and cracked the head so i found another head and put it on i replaced the timing belt while i was that far now i have it all back together and i have no spark...i forgot to disconect the battery does that have and thing to do with it ....does the crank sensor have anything to do with spark ??? this is my only vehicle and i need it back quick so some body please help me
Reply With Quote
  #2  
Old 06-07-2007
TireIron's Avatar
Member
 
Join Date: Feb 2006
Location: Methuen, MA
Posts: 790
when you swapped the head back on did you make sure all the electrical connections are hooked up properly and the plug wires are run correctly? when you put the timing belt on did you time the engine correctly and the crank sensor isn't damaged right?
Reply With Quote
  #3  
Old 06-07-2007
Member
Thread Starter
 
Join Date: Jun 2007
Location: shamokin p.a.
Posts: 9
well my step dad bent up the tab comming off the back of the harmonic balencer and i think it might have messed it up ....what does the crank censor do ? besides that i did every thing else right its in time and evrythings hooked up back to the way it was before i started
Reply With Quote
  #4  
Old 06-08-2007
TireIron's Avatar
Member
 
Join Date: Feb 2006
Location: Methuen, MA
Posts: 790
yea, you will want to pull the hub back off and make sure the tabs are in the correct place, or better yet just grab another unbent hub from the junk yard and then make sure the crank sensor isn't damaged and if it is bolt another one and check the clearance to make sure the hub vanes dont hit the sensor. without this sensor functioning correctly you will never get spark from the coils.
Reply With Quote
  #5  
Old 06-10-2007
Member
Thread Starter
 
Join Date: Jun 2007
Location: shamokin p.a.
Posts: 9
thanks a bunch im picken them up tomorrow
Reply With Quote
  #6  
Old 06-12-2007
TireIron's Avatar
Member
 
Join Date: Feb 2006
Location: Methuen, MA
Posts: 790
let me know how it comes out and just be sure when you install the new sensor that the vanes in the hub dont hit it and the clearance is good.
Reply With Quote
  #7  
Old 06-22-2007
Member
Thread Starter
 
Join Date: Jun 2007
Location: shamokin p.a.
Posts: 9
everythings great the trucks runnin better then ever thanx for your help
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Spark Plugs Wires & Spark Plugs vancouverisland 4.0L OHV & SOHC V6 Tech 8 07-26-2017 12:28 AM
spark plugs and wires gatorblue92 2.9L & 3.0L V6 Tech 18 10-04-2005 09:20 PM
Spark plugs & wires Diabolic SOHC - 2.3L & 2.5L Lima Engines 9 03-28-2005 04:49 PM
spark plugs 04edge 2.9L & 3.0L V6 Tech 14 03-17-2005 03:58 PM
Noise supression / shielded spark plugs and wires?? FireRanger General Ford Ranger Discussion 13 11-04-2004 06:34 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.