Still need help! - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-13-2008
Member
Thread Starter
 
Join Date: Jun 2008
Location: Paris, IL
Posts: 14
Icon9 Still need help!

My Engine is still running lean! I ran the gas tank almost empty and loaded it up with fuel injector cleaner and water remover. Then I filled it back up with a mid grade gas. I am still getting a crackling sound when I accelerate. My mechanic thought he had it fixed but when I picked it up today the check engine light came back on again. It seems to come on about a half a mile down the road after the code has been cleared and the car has been turned off. I also changed the fuel filter. What should I do? The only thing I can think of is to replace the o2 sensor but that won't get rid of the crackling sound when I accelerate.
Reply With Quote
  #2  
Old 06-13-2008
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
are you actually throwing a code? like Bank 1 lean?

and yes a bad 02 sensor can cause it to run lean...
Reply With Quote
  #3  
Old 06-13-2008
Member
Thread Starter
 
Join Date: Jun 2008
Location: Paris, IL
Posts: 14
yes it is saying bank 1 running lean. But I was also concerned about the crackeling I am getting when I accelerate. What are your thoughts?
Reply With Quote
  #4  
Old 06-14-2008
jeremy4876's Avatar
Member
 
Join Date: Apr 2008
Location: Elyria Township
Posts: 98
Any holes /cracks in the exhaust? My wife's minivan(yeah I know ,it's not a Ranger) had a pinhole leak in the muffler and it caused the van to throw out a code for the EGR valve.Put on a new muffler ,code went away. Just my 2 cents.Good luck
Reply With Quote
  #5  
Old 06-14-2008
jeremy4876's Avatar
Member
 
Join Date: Apr 2008
Location: Elyria Township
Posts: 98
Oh yeah ,what am I thinking! I had a Ranger do the same thing ! Small exhaust leak, caused check engine light and failed tailpipe emissions test. Code was for O2 sensor,but fixed leak & retested and passed w/flying colors
Reply With Quote
  #6  
Old 06-14-2008
Member
Thread Starter
 
Join Date: Jun 2008
Location: Paris, IL
Posts: 14
would that cause the engine to make a crackling noise when you accelerate?
Reply With Quote
  #7  
Old 06-14-2008
67cobain94's Avatar
Member
 
Join Date: Jul 2005
Location: Vero Beach, Florida
Posts: 708
Yes an exhaust leak will cause a crackling noise. Try pushing all of the air out of a tiny hole before it has to go out the tailpipe. Lean codes are set by either exhaust leaks or vacuum leaks. Check both.
Reply With Quote
  #8  
Old 06-14-2008
Member
Thread Starter
 
Join Date: Jun 2008
Location: Paris, IL
Posts: 14
awesome thanks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
anyone still still using halogen bulbs here check out this harness cheese_man General Technical & Electrical 4 12-29-2013 11:02 PM
Still having seat belt Chim/Buckle Problem. Need Help entress88 General Technical & Electrical 3 08-13-2010 12:21 AM
ABS still acting up... need big time help Alon General Technical & Electrical 15 01-20-2008 01:00 AM
Brakes still messed up, need help, please! MadMaxRanger Drivetrain Tech 5 10-08-2006 02:29 AM
I still need help on FX4 Emblem Austin1 New Ideas 15 06-28-2005 08:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:51 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.