Wipers! Having Trouble - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-20-2009
Member
Thread Starter
 
Join Date: Aug 2009
Location: Warwick , R.I
Posts: 11
Icon4 Wipers! Having Trouble

Just happened today , my wipers wont go on . wont even turn on the washer fluid. checked juice in the plug into the motor.. thats good, fuses are good , any one have any ideas ,
Reply With Quote
  #2  
Old 08-20-2009
paintballer4758's Avatar
Member
 
Join Date: Aug 2009
Location: Renton, WA
Posts: 235
i would try pullin the motors and seein if they have power... and if they are no good they either go to a junk yard and buy some motors for them outa there or if they dont have them try lookin for some new ones

but it could be as simple as a fuse but im no mechanic just some easy generally cheap things to try...
Reply With Quote
  #3  
Old 08-20-2009
ns_red7's Avatar
Member
 
Join Date: May 2007
Location: Coldbrook, Nova Scotia, C
Posts: 558
If I had to put money on it, my $$ would be on a bad multi-function switch.

They are known for being problematic.
Reply With Quote
  #4  
Old 08-20-2009
ns_red7's Avatar
Member
 
Join Date: May 2007
Location: Coldbrook, Nova Scotia, C
Posts: 558
As a side note I find it funny that 2 paintballers were the first to reply to your "having trouble with wipers" thread. Lol light em up!
Reply With Quote
  #5  
Old 08-20-2009
malydeen's Avatar
Member
iTrader: (12)
 
Join Date: Jul 2007
Location: Minneapolis, MN
Posts: 632
mine have the same problem. You'll learn to live with it.

RainX is your best friend now.
Reply With Quote
  #6  
Old 08-20-2009
hozII's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: athens, Al
Posts: 2,245
Sounds like your mutifunction switch is bad. If your gettin power to the motor but wipers and washer's wont work..that def sounds like a good candidate!!
Reply With Quote
  #7  
Old 08-31-2009
johndeeregarner's Avatar
Member
 
Join Date: Aug 2009
Location: Memphis
Posts: 157
Test the power to it. If it doesn't have any then you need to go back down the wire and check the next available connection and so on. You'll find the problem soon enough.
Reply With Quote
  #8  
Old 09-01-2009
RodeoBum09's Avatar
Member
 
Join Date: Jan 2008
Location: In The Hardwoods
Posts: 144
Quote:
Originally Posted by Cabral401 View Post
Just happened today , my wipers wont go on . wont even turn on the washer fluid. checked juice in the plug into the motor.. thats good, fuses are good , any one have any ideas ,

Im going to say its a faulty switch. Checked the fuses? If the fuses, and all your connections are good. Id bed its the switch. Try Rockauto.com...for cheap switches.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Having trouble starting my truck volcompro11 2.9L & 3.0L V6 Tech 3 10-21-2007 02:25 AM
member having trouble getting to the site. zabeard Ranger-Forums Office 37 11-19-2005 12:23 AM
Anyone else having trouble getting ahold of Doug? Gearhead61 General Ford Ranger Discussion 12 08-12-2005 04:24 PM
Level II Bilsteins... having trouble installing ThatGuy Suspension Tech 6 06-16-2005 10:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:16 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.