14mgp...... - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-28-2006
ks ranger's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: KS
Posts: 273
14mgp......

What do you guys think is causing that? It's completely stock and I shift between 2500-3000. I don't have a heavy foot either. The only thing i can think of is I have a crack in my exhaust pipe in between my cat and glass pack. It's about 8" long... I don't see how that could cause me to get that bad of gas mileage though...
Reply With Quote
  #2  
Old 11-30-2006
ks ranger's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: KS
Posts: 273
anyone?
Reply With Quote
  #3  
Old 11-30-2006
JASONGR81's Avatar
Member
 
Join Date: Nov 2006
Location: SPRINGFIELD, OHIO
Posts: 96
I Have A Simliar Problem. I Get About 12-14 Mpg City And 15-17 Highway. I Have A 2000 Ranger With A 3.0 4x4 5 Spd 112k Miles. Flowmaster Dual Exhaust With K&n.
Anyone Know Why Such Bad Gas Mileage?
Reply With Quote
  #4  
Old 11-30-2006
ks ranger's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: KS
Posts: 273
My 14mpg is probably 3/4 highway to.... I wonder where everyone is..
Reply With Quote
  #5  
Old 11-30-2006
xp1ik99's Avatar
Member
iTrader: (5)
 
Join Date: Feb 2006
Location: Lexington Park, MD
Posts: 3,230
that sucks is all i can say, maybe a tune up is in order, i just drove 500miles to ny with my truck on 35's and 4.10's auto and i was getting 16mpg......
Reply With Quote
  #6  
Old 11-30-2006
ks ranger's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: KS
Posts: 273
Quote:
Originally Posted by xp1ik99
that sucks is all i can say, maybe a tune up is in order, i just drove 500miles to ny with my truck on 35's and 4.10's auto and i was getting 16mpg......
Idk, that's kinda what I thought. That and fix my exhaust. What all exactly shouldyou do for a tune-up?
Reply With Quote
  #7  
Old 11-30-2006
RicksTJR's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2006
Location: Dyersburg, TN
Posts: 524
Im getting that with a lift and 33's
Reply With Quote
  #8  
Old 11-30-2006
TommyC's Avatar
Member
iTrader: (1)
 
Join Date: Jun 2006
Location: CA
Posts: 1,012
eh I'm getting that stock =(
Reply With Quote
  #9  
Old 12-01-2006
Bhavesh's Avatar
Member
 
Join Date: Oct 2006
Location: City, State
Posts: 507
old ranger?
Reply With Quote
  #10  
Old 12-01-2006
xp1ik99's Avatar
Member
iTrader: (5)
 
Join Date: Feb 2006
Location: Lexington Park, MD
Posts: 3,230
no it says in his signature its an 06, must have a case of heavy foot, hell idk what everything in a tune up would consist of, i changed out my plugs and wires, fuel filter, cleaned my air filter and changed the oil and i considered that a "mini tune-up", you could flush all your fluids as well and that may help, i flushed my radiator and my truck felt like a champ afterwards......
Reply With Quote
  #11  
Old 12-01-2006
Jeremy102579's Avatar
Member
 
Join Date: Jun 2006
Location: North Tonawanda, NY
Posts: 431
i have a 1994 3.0 stick super cab 4x4 with 163,000 and went 190 miles and filled back up 10.25 gallons....comes out to alittle over 18 miles per gallon city and highway combined.
Reply With Quote
  #12  
Old 12-01-2006
Bhavesh's Avatar
Member
 
Join Date: Oct 2006
Location: City, State
Posts: 507
Quote:
Originally Posted by xp1ik99
no it says in his signature its an 06, must have a case of heavy foot, hell idk what everything in a tune up would consist of, i changed out my plugs and wires, fuel filter, cleaned my air filter and changed the oil and i considered that a "mini tune-up", you could flush all your fluids as well and that may help, i flushed my radiator and my truck felt like a champ afterwards......
no, I meant for the original poster, who has a '92

I figure any older vehicle will get worse gas mileage than a newer one.
Reply With Quote
  #13  
Old 12-01-2006
xp1ik99's Avatar
Member
iTrader: (5)
 
Join Date: Feb 2006
Location: Lexington Park, MD
Posts: 3,230
maybe, could be a number of different things that play into the mpg........ive got 135k on my truck and it still runs top and get good mpg's
Reply With Quote
  #14  
Old 12-01-2006
ks ranger's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: KS
Posts: 273
Yeah, 160k here but still runs good.
Reply With Quote
  #15  
Old 12-01-2006
CadiLLacPimPin's Avatar
Member
 
Join Date: Nov 2006
Location: Charlottesville, VA
Posts: 239
The 3.0 is fuel injected isnt it? Probably a bad o2 sensor if so.
Reply With Quote
  #16  
Old 12-01-2006
rebel3.0's Avatar
Member
 
Join Date: Sep 2005
Location: Yarmouth Nova Scotia
Posts: 68
Dont forget to check your tire pressure. That can make a big diffrence.
Reply With Quote
  #17  
Old 12-01-2006
Member
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,046
i get about 16.5 with daily 90% city/10% highway driving, and i have a 2wd 3.0 with 30" tires. (stockers were 26~ish, i believe)
Reply With Quote
  #18  
Old 12-01-2006
xp1ik99's Avatar
Member
iTrader: (5)
 
Join Date: Feb 2006
Location: Lexington Park, MD
Posts: 3,230
Quote:
Originally Posted by CadiLLaPimPin
The 3.0 is fuel injected isnt it? Probably a bad o2 sensor if so.
there isnt to many engines out there now adays that arnt fuel injected......
Reply With Quote
  #19  
Old 12-02-2006
CadiLLacPimPin's Avatar
Member
 
Join Date: Nov 2006
Location: Charlottesville, VA
Posts: 239
Quote:
there isnt to many engines out there now adays that arnt fuel injected......
Mine aint! Never will be either.

I just wasnt sure if they had all gone fuel injected by that time or not.
Reply With Quote
  #20  
Old 12-02-2006
claytonrduvall's Avatar
Member
 
Join Date: Nov 2006
Location: florence
Posts: 115
i have the same prop on my truck , i have a 99 with onyl 75k on her and its been getting about 11-13 hwy miles since i have owned her and i have done the complete mini tune up and every thing also the os, any other ideas on how to fix
Reply With Quote
  #21  
Old 12-02-2006
xp1ik99's Avatar
Member
iTrader: (5)
 
Join Date: Feb 2006
Location: Lexington Park, MD
Posts: 3,230
god damn man, trade it in..........thats awful, is it all stock?????
Reply With Quote
  #22  
Old 12-02-2006
Bhavesh's Avatar
Member
 
Join Date: Oct 2006
Location: City, State
Posts: 507
ok...on my last tank I got ~16.3mpg (50/50, city/highway) on my '91 2wd 3.0. So aren't all of our gen2 3.0's pretty bad on gas mileage to begin with?
Reply With Quote
  #23  
Old 12-02-2006
xp1ik99's Avatar
Member
iTrader: (5)
 
Join Date: Feb 2006
Location: Lexington Park, MD
Posts: 3,230
idk but 16.3 with half and half driving isnt bad.....
Reply With Quote
  #24  
Old 12-02-2006
T4EaterJonny's Avatar
Member
 
Join Date: Nov 2006
Location: California
Posts: 63
I think its how people are calculating their gas milage. I never fill up my tank all the way so I don't know hwo bad mine is.
Reply With Quote
  #25  
Old 12-03-2006
ks ranger's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: KS
Posts: 273
Quote:
Originally Posted by CadiLLaPimPin
The 3.0 is fuel injected isnt it? Probably a bad o2 sensor if so.
Doesn't your CEL come on if you have a bad o2 sensor?
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:19 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.