3.0 misfire - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-18-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Chicopee,Mass
Posts: 30
3.0 misfire

i have had my truck 2 years now i got about 179500 on it. i bought it everything was perfect. i got inspected and right when i left my rear drvier side shackle went like two mins after leaving inspection. then about a month later i got a misfire changed all the plugs wire and plugs. i put seafoam in it didnt work. i have had about 3 misfires now. they come and go. can anynoe help me out here please. i'm trying to get to the bottom of this. thanks mat
Reply With Quote
  #2  
Old 07-18-2010
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
Check the hose coming from the intake to the pcv valve.After you drive for a little while look to see if it is collapsing at the elbow part.
My truck has !72k on it and around 170k started running like crap.I changed plugs and stuff,was good for a day then back to crap.I noticed hose.Got new hose and pcv vale truck runs like new.
I also reccommend E3 plugs.Was long time autolite fan(all i ever used in the ranger)thought I would give something else a try;glad I did.Plugs are awesome.
Reply With Quote
  #3  
Old 07-18-2010
d0sitmatr's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
Quote:
Originally Posted by BigEdge126 View Post
Check the hose coming from the intake to the pcv valve.After you drive for a little while look to see if it is collapsing at the elbow part.
My truck has !72k on it and around 170k started running like crap.I changed plugs and stuff,was good for a day then back to crap.I noticed hose.Got new hose and pcv vale truck runs like new.
I also reccommend E3 plugs.Was long time autolite fan(all i ever used in the ranger)thought I would give something else a try;glad I did.Plugs are awesome.
something I hadnt heard before, I will give that a look and see if maybe that is what is causing my random bogging issues.
Reply With Quote
  #4  
Old 07-19-2010
Member
 
Join Date: May 2010
Location: vassar, MI
Posts: 30
hey man is that gunna be the same for a 99
Reply With Quote
  #5  
Old 07-19-2010
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
I am not sure.I know they changed to a plastic intake my year but I think they all have that hose coming out the intake into the pcv.
Reply With Quote
  #6  
Old 07-19-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Chicopee,Mass
Posts: 30
i dont think its the pcv tho. i heard its a seal on one of the intake valves. but idk i need help lol. see i cahnge the plugs and wires and still runs the same like crap. idk one day i left it idling for about 2 hours and its cleared up. i havent done it yet but i will this weekend. and my buddy works at a shop has the top on the line snap on computer for check engine lights etc. and everytime it says cylinder 6 misfire feul injector failed.
Reply With Quote
  #7  
Old 07-20-2010
99greenranger's Avatar
Member
 
Join Date: Mar 2010
Location: Garden City, MI
Posts: 126
i also have the cylinder 6 misfire that will not go away hopefully something here will help me find what is wrong with my motor.
Reply With Quote
  #8  
Old 07-22-2010
tx03edge's Avatar
Member
 
Join Date: Apr 2007
Location: Dallas, Tx
Posts: 73
I understnad what yall are going thru I am also getting a misfire code "cylinder 2 misfire"
My truck will run crapy and not throw a code for months, then all of a sudden tit will throe a code. I have changed all the plugs & wires, and still crappy...any suggestions?
Reply With Quote
  #9  
Old 07-22-2010
tx03edge's Avatar
Member
 
Join Date: Apr 2007
Location: Dallas, Tx
Posts: 73
could you shoot some pictures of the pcv valve your talking about?
Reply With Quote
  #10  
Old 07-22-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Chicopee,Mass
Posts: 30
hey tx03edge i found alot of pics on google. check them out just type in ford ranger pcv valve and look at the images
Reply With Quote
  #11  
Old 07-25-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Chicopee,Mass
Posts: 30
i gotta make a road trip to hampton beach in 2 weeks. its about 140 miles there and then 140 back. total round trip 280 with a misfire it should be fine right?
Reply With Quote
  #12  
Old 07-25-2010
d0sitmatr's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
well, my truck is still acting up and I was forced to do a 420m drive last week and it was ok, but I babied it. in all honesty, I wouldnt do it if you can avoid it or find another vehicle to use.
Reply With Quote
  #13  
Old 07-26-2010
Member
 
Join Date: May 2010
Location: vassar, MI
Posts: 30
guys i got it for the guy with the 6 misfire pull number 6 plug i had the same problem and found out my head gasket was blown but now that i have my heads off my upper and lower intakes are gettin ported and polished along with my heads =D so check that out man
Reply With Quote
  #14  
Old 07-30-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Chicopee,Mass
Posts: 30
I was looking to see if anything was leaking and finding a way to figure out the misfire. and i was playing with the vaccum lines all of them have vaccum accept one. i'm wondering if that would have anything to do with the misfire. its the grreen line. and i'm going to play with it after work and see what is does. hopefully it fixs it
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
cylinder 4 misfire skankinandy SOHC - 2.3L & 2.5L Lima Engines 20 10-15-2015 03:26 AM
Misfire 4,5,6 help. JDRead 2.9L & 3.0L V6 Tech 10 09-24-2008 02:10 AM
help misfire after i washed engine? vic 2.9L & 3.0L V6 Tech 3 08-13-2006 01:37 PM
Engine misfire???? phatspeed7x 4.0L OHV & SOHC V6 Tech 4 07-02-2006 09:08 AM
Misfire TBarCYa 4.0L OHV & SOHC V6 Tech 5 02-23-2005 11:14 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.