99 3.O 4x4 guzzling gas? Any ideas? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-14-2011
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
99 3.O 4x4 guzzling gas? Any ideas?

My brother's truck is guzzling gas. It's not throwing any codes or even running rough just really thirsty.

I've glanced around the hoses and can't find a vacuum leak or anything out of the ordinary. Maybe an EGR problem? O2 sensor? MAF?

Go any suggestions?

Thanks.
Reply With Quote
  #2  
Old 09-14-2011
Sonic04Edge's Avatar
RF Veteran

iTrader: (6)
 
Join Date: Jun 2004
Location: Madison. AL
Posts: 5,715


Maybe?
Reply With Quote
  #3  
Old 09-14-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by Sonic04Edge View Post


Maybe?
I was going to say, Its casue its a 3.0.
Reply With Quote
  #4  
Old 09-14-2011
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
That could very well be it. But I asked if he was getting in it and he said no. He just got his license not to long ago and still drives like an old person to tell you the truth.

It wasn't this bad on gas when he got it. Hell his mileage is worse than what I'm getting in my truck. lol

So I'm thinking somethings got to be up. Just trying to help him out if I can.
Reply With Quote
  #5  
Old 09-14-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by seed60 View Post
That could very well be it. But I asked if he was getting in it and he said no. He just got his license not to long ago and still drives like an old person to tell you the truth.

It wasn't this bad on gas when he got it. Hell his mileage is worse than what I'm getting in my truck. lol

So I'm thinking somethings got to be up. Just trying to help him out if I can.
Do a tune up? fuel filter, plugs, wires. air filter. those things.
Reply With Quote
  #6  
Old 09-15-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Is the tranny shifting into high gear like it should or is it hanging in second?
Also check the temperature sensor for the PCM. If it reads cold all the time the engine will stay in open loop mode running a richer mixture.
Reply With Quote
  #7  
Old 09-15-2011
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Quote:
Originally Posted by StxDangerRanger View Post
Do a tune up? fuel filter, plugs, wires. air filter. those things.
Fuel filter was done maybe 6 months ago, along with air filter. Plugs and wires probably could use a changing.

Quote:
Is the tranny shifting into high gear like it should or is it hanging in second?
Also check the temperature sensor for the PCM. If it reads cold all the time the engine will stay in open loop mode running a richer mixture.
Not sure about that. I'll have to give it a test drive.

Thanks for the ideas.
Reply With Quote
  #8  
Old 09-15-2011
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
i averaged around 16 highway on 33s. my truck wasn't horrible on gas it just sucked when it downshifted and rev at like 3k lol
Reply With Quote
  #9  
Old 09-15-2011
Sonic04Edge's Avatar
RF Veteran

iTrader: (6)
 
Join Date: Jun 2004
Location: Madison. AL
Posts: 5,715
Quote:
Originally Posted by 99offroadrngr View Post
i averaged around 16 highway on 33s. my truck wasn't horrible on gas it just sucked when it downshifted and rev at like 3k lol
Kinda off topic, but kinda a funny story. When I had 265's on the blue 4x I only got 17hwy. Here I am in the exploder and I am doing almost 20hwy with a slightly smaller tire. Same gear ratio. Only difference is the exploder is auto 4x4 and the ranger was manual. You'd think it would be the other way around since the explorer is heavier.
Reply With Quote
  #10  
Old 09-16-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by Sonic04Edge View Post
Kinda off topic, but kinda a funny story. When I had 265's on the blue 4x I only got 17hwy. Here I am in the exploder and I am doing almost 20hwy with a slightly smaller tire. Same gear ratio. Only difference is the exploder is auto 4x4 and the ranger was manual. You'd think it would be the other way around since the explorer is heavier.
and since the 4x freewheeled more cause it was manual.
I blame the tires.
Reply With Quote
  #11  
Old 09-16-2011
Sonic04Edge's Avatar
RF Veteran

iTrader: (6)
 
Join Date: Jun 2004
Location: Madison. AL
Posts: 5,715
Quote:
Originally Posted by StxDangerRanger View Post
and since the 4x freewheeled more cause it was manual.
I blame the tires.
Gas mileage was pretty much the same from the stock 245's to the 265's to the 305's lol.
Reply With Quote
  #12  
Old 09-23-2011
Level III Supporter
iTrader: (2)
 
Join Date: Nov 2010
Location: Maine
Posts: 1,220
I've noticed that in order to get any kind of decent mileage out of my 3.0, I've got to be running around 70-75 on the highway. Otherwise, it likes to drop out of overdrive fairly often because it has no *****. I typically see between 18 and 20 MPG out of mine, depending on how much driving I do around town.
Reply With Quote
  #13  
Old 10-07-2011
Member
 
Join Date: Sep 2011
Location: manchester nh
Posts: 46
hes not driving around with 4x4 on all the time is he?
Reply With Quote
  #14  
Old 10-07-2011
Member
 
Join Date: Aug 2011
Location: Thornton,Co
Posts: 5
My 99 ranger gets terrible milage, burns through a quarter of a tank to just go 50 miles, so im having the same problem also
Reply With Quote
  #15  
Old 10-11-2011
Member
 
Join Date: Oct 2011
Location: Bowling Green Ky
Posts: 57
I get about 20 on the hwy with mine and no tonneau cover..I usually run abt 75-85 mph on the hwy and I got stock 3.73's
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2.3 gas tank to 4.0 gas tank, fuel pump q njdriver04 DOHC - 2.3L Duratec / Mazda L Engines 1 09-13-2012 11:43 AM
Need Custom 5gl Gas Can Mount Ideas Rev Fabrication & Tool Tech 8 06-13-2007 08:54 PM
No gas gage, gas smell by the bed, pictures CadiLLacPimPin General Ford Ranger Discussion 8 01-23-2007 08:57 PM
do k&n air intakes save gas or lose gas RangerEdge17 4.0L OHV & SOHC V6 Tech 26 09-19-2006 03:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:39 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.