Belt Squeeking! - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 04-03-2008
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
It's a Ranger thing....you're not going crazy. LOL

1st off, replace the belt with a Gatorback.....nothing else will do.

If it's still there, then replace the tensioner pulley and idler pulley. The Gatorback will help right off the bat. Mine used to squeal when the weather got damp and rainy. The first week of having the truck I brought it back several times because of the squeal....and all Ford did was put belt dressing on it.....what a waste of time. Let me tell you something...if you ever want to waste money and throw it out the window, buy belt dressing...the worst sh*t you can buy.

Finally they replaced the tensioner and idler under warranty, but that never fixed anything. I went a got a Gatorback, been squeal free for 5 years now.
Reply With Quote
  #27  
Old 04-10-2008
therangerofdanger's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2007
Location: Raleigh, North Carolina
Posts: 618
i had this problem on mine. I replaced the tensioner and the idler and the belt. Not much changed, but it did get a little better. I DO KNOW WHAT MY PROBLEM IS THOUGH>>>
If i stare at the tensioner pulley, I can actually watch the belt walk back and forth on the pulley. I spent forever trying to fig it out; then i noticed that not all of my pulleys are 100% planar, so there is nothing I can really do about that... but when it has rained, you can actually watch the squeek coresponding to the 'walking' on the tensioner pulley
Reply With Quote
  #28  
Old 05-14-2008
canesfan101's Avatar
Member
 
Join Date: Jan 2008
Location: Hoover, AL
Posts: 61
i have a squeaking problem, but only when i start my truck. i have no idea what it is anyone have an idea
Reply With Quote
  #29  
Old 12-25-2008
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
HAHA BAck from the dead because i havent fixed my problem yet lol... It never really bothered me because im from phx, az. Its so Dry and hot there and barely gets wet so i never hear a squeal, then Im here in Austin on vacation and it has been rainy, cold, foggy, damp, and humid and the squeal comes back full force. I was embarressed to drive my truck one night because it was sooo loud :(
Reply With Quote
  #30  
Old 12-25-2008
Fenech627's Avatar
Member
iTrader: (1)
 
Join Date: Dec 2007
Location: Detroit, MI
Posts: 908
I hate the noise to no end. Mine just last night I think when I started it up. There is no way to stop it your in the humidity and mugginess its going to squeak.
Reply With Quote
  #31  
Old 12-25-2008
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
im swapping pulleys(idler and tensioner) if that doesnt work, Belt with some new lightweight pulleys from underdog, if that doesnt work then water pump then if that doesnt work, im hitting my 3.0L motor with a freakin sledge hammer and putting in a 5.0!
Reply With Quote
  #32  
Old 12-25-2008
99ranger4x4's Avatar
RF Veteran
iTrader: (3)
 
Join Date: Jun 2006
Location: Austin, TX
Posts: 12,198
what are you doing right now?

come over, its pretty easy to figure out what pulley is making noise. There's no need to toss money at it until you fix it lol.



...i say this now, but with my luck i would find anything.
Reply With Quote
  #33  
Old 12-27-2008
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
BAHAHHAHAHAAH I fixed it.... I just slapped in a GatorBack Belt and it fixed the problem, hellllllllls ya!
Reply With Quote
  #34  
Old 12-27-2008
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Quote:
Originally Posted by MudSlanger View Post
BAHAHHAHAHAAH I fixed it.... I just slapped in a GatorBack Belt and it fixed the problem, hellllllllls ya!
Almost a year from the OP and you finally fixed it........and to bring a thread back from the dead to tell us....WOW!!

Just should have followed our advise from way back in March!!!! Your problem was solved waaaaaaaaaaaaaaaaaaaaaaaaaaaay back then, you just never did it.
Reply With Quote
  #35  
Old 12-27-2008
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Quote:
Originally Posted by Fenech627 View Post
I hate the noise to no end. Mine just last night I think when I started it up. There is no way to stop it your in the humidity and mugginess its going to squeak.
Yes there is, re-read this thread and you'll find your fix....here's a clue...it's a belt.

Reply With Quote
  #36  
Old 12-27-2008
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
Well it was ONLY a problem when i was in a moist, damp, wet place such as TEXAS this time of year... Living in Phoenix, AZ where its dry and RARELY ever wet or humid, The problem was hardly ever there so it never bothered me. But making my way back down to Austin, TX for a couple weeks where it was wet about 3/4 of the time ive been here and having to hear the squeek on a daily basis finally decided to do something about it.

But you were right and now i fixed it... and WOW is right, why should i make another thread telling people i fixed my belt problem. It just made sense to let people know in my original thread. Saves wasted and pointless threads! :)
Reply With Quote
  #37  
Old 12-27-2008
ColdNapalm's Avatar
Member
 
Join Date: Sep 2008
Location: Jacksonville, Florida
Posts: 499
my ranger doesn't squeak when it rains but it does after i drive through a flood or into a deep hole :) just tighten up your belt a little bit thats all it took for me..
Reply With Quote
  #38  
Old 12-29-2008
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Quote:
Originally Posted by ColdNapalm View Post
my ranger doesn't squeak when it rains but it does after i drive through a flood or into a deep hole :) just tighten up your belt a little bit thats all it took for me..


Missed the whole thread I guess.
Reply With Quote
  #39  
Old 12-30-2008
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
For all belt squeeky issues:

Here is a nice little check that will possibly save you a bunch of money replacing crap;

Take a bottle of water.. with your truck running, spray/pour water on the belt.. if the squeek goes away; its a bad belt: Buy a gatorback and it should fix it.
Reply With Quote
  #40  
Old 01-10-2009
Member
 
Join Date: Mar 2006
Location: Spring Hill, KS
Posts: 22
I got a Tensioner pulley and arm from amazon.com for $40 shipped and added a Gatorback (thanks to all the recommendations on here) and all squeaking was gone.

Rain and heavy humidity was all mine took to squeal like a stuck hog. I tried teh belt dressing first, had to spray it at least once a week though. Maybe an hour or 2 to replace everything and all is good!
Reply With Quote
  #41  
Old 01-10-2009
Blackonblackfx4's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: Edmonton, Alberta
Posts: 914
I blew the hormonic balancer in mine, and the auto tentioner went with it, after it came out of the shop it still was making noise so i threw a goodyear gatorback belt on it and it's silent now, you can get them from summit
Reply With Quote
  #42  
Old 01-31-2009
Reddsurion's Avatar
Member
 
Join Date: Sep 2008
Location: Brunswick, GA
Posts: 22
I replaced mine due to it was cracked and I was going on a long trip. I made it to the place of desination and less than a week the new belt was squeaking. I first thought it was the idler pulley going bad. I had brought the old belt for emergency use. I put the old one back on and the squeak went away. The new one was an Advanced Auto parts brand and after I measured the width the new one was .040-.050" wider than the old one and .030-.040 wider than the original brand belt. I am currently running the original brand belt with no squeaks.
Reply With Quote
  #43  
Old 03-29-2009
4x4RangerOffroad's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: Barrington, NH
Posts: 434
All mine does is make squeak......so gator back should help its makeing new belts squeak ever 3 weeks..its after going wheeling or getting wet.
Reply With Quote
  #44  
Old 03-29-2009
LuckyRanger13's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2007
Location: Santa Fe, TN
Posts: 554
When it has been raining your engine has condensation on it, that's why the 3.0 squeaks when it's been raining. Also because of worn parts.
Reply With Quote
  #45  
Old 03-30-2009
4x4RangerOffroad's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: Barrington, NH
Posts: 434
it squeak 24/7...dry/wet doesnt matter...new belt and its fien for about 2-3 weeks unless I go wheeling......It has new idler, tensioner, crank, fan, and still...but oh well I just ordered the gator back...we'll see
Reply With Quote
  #46  
Old 03-30-2009
Xplo's Avatar
Member
 
Join Date: Apr 2007
Location: Norcross, GA
Posts: 83
My 3.0L also squeaks sometimes after it rains, and replacing the belt didn't help it. I tried some WD-40 on different pullies one time while it was doing it and it stopped for about 4 seconds when I sprayed the idler pulley. So, I replaced it and now instead of squeaking a lot all the time, it just squeaks a little sometimes. It was probably just dirty and still is.
Reply With Quote
  #47  
Old 03-31-2009
mossyoak1992's Avatar
Member
 
Join Date: Jan 2008
Location: Bridgeton, N.J.
Posts: 383
my belt squeeks too and i am 99% sure it already has a gatorback on it cuz it looks exactly like a gator back belt i just cant find a logos or anything on it
Reply With Quote
  #48  
Old 03-31-2009
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Quote:
Originally Posted by mossyoak1992 View Post
my belt squeeks too and i am 99% sure it already has a gatorback on it cuz it looks exactly like a gator back belt i just cant find a logos or anything on it
If it looks like this:



It's a Gatorback.
Reply With Quote
  #49  
Old 03-31-2009
kyle12201's Avatar
Member
 
Join Date: Apr 2008
Location: East Waterboro, ME
Posts: 1,543
Mine does this when its wet too.. no biggy
Reply With Quote
  #50  
Old 04-01-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
gator back FTW
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ser. Belt Squeeking- Help! Robot_ 4.0L OHV & SOHC V6 Tech 14 08-27-2006 03:54 PM
Front End Squeeking HighRollerII General Ford Ranger Discussion 11 05-26-2006 09:59 AM
Squeeking 05rangeredge Suspension Tech 14 04-16-2006 04:59 PM
squeeking pulley... jtslmn720 2.9L & 3.0L V6 Tech 21 04-04-2006 06:06 AM
Belt Squeeking??? Help!! jrsmith313 General Technical & Electrical 17 11-25-2005 10:26 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.